Problem when generating a new rig.conf

Hi Friends,

I have a problem when i’m trying to generate a new rig.conf, the miner is missing.
Although i fill in all the fields on the Hive web interface, the selected miner (i.e T-Rex Miner) does not implement in the rig.conf file.

If I use this rig.conf file on my usb key, the rig does not work and indicate this following message in yellow : no miner is set in config.

It is my third rig and I never had this problem before.

Here’s the rig.conf :

### MINERS HIVE CONFIG ################################

#URL where hive server is
HIVE_HOST_URL=“http://api.hiveos.farm

#Id of the rig, numeric value from admin panel
RIG_ID=1540749

#Rig password as in admin panel
RIG_PASSWD=“miner”

#Rig hostname
WORKER_NAME=“Rig_1660s”

#Id of the farm
FARM_ID=689058

#Selected miners
MINER=
MINER2=

#Rig timezone
TIMEZONE=“Europe/Amsterdam”

#Watchdog
WD_ENABLED=0

#Hive Shell server host
HSSH_SRV=“shell.hiveos.farm”

#Options

Thanks a lot for your help.
Greetings from France.

What do you want from config file?
It has only 2 major variables RIG_ID and RIG_PASSWD
All other settings server will send to rig and than rig saves it to rig.conf

Setup your rig - wallet, flight sheet …

Ah ok I thought it was the inverse ^^
Then why do I have the message : “No miner is set in config” ??

Because you don’t have active Flight Sheet (FS) on your worker
Create new FS or apply existent to worker and this message will disappered and your worker will start mining

Or you somehow saved FS without miner set … but it’s sounds like nonsense (Hive not allowed save FS without miner AFAIK)

Okay I will make a new FS maybe the actual one has a bug.
Thank you very much.

OK problem solved.
Thank you for your help.