Problems with GPUs hanging (OpenCL error) (SOLVED)

bios
asrock-h110-pro-btc
#1

I’m here just to tell you what was happening on my rig and what I’ve done to fix it, so we can have more info here on the forum for future problems.

First, my rig:
MOBO: Asrock H110 BTC PRO
PROC: Intel Celeron G3990
RAM: 8gb
SSD: 120gb
GPU AMD: 8x XFX RX580 8GB OC+ XXX
GPU NVIDIA: 3x ZOTAC MINI 1070 8GB
POWER: 3x CORSAIR CX750 (1x with rig base + 3 1070, 1x with 4 RX580 and 1x with more 4 RX580).

Yep. Hybrid rig. 11 GPUs total.

When I tried Hive for the first time, I had frequent problems with two gpus hanging. Always the same gpus. I’ve tried to change risers, lower overclock, tried all the PCIe configs on the bios (Gen1, Gen2 and Auto), with display on onboard gpu and on offboard gpu, and a bunch more stuff. NOTHING worked. So I stayed on Windows. (=/)

Yesterday, Windows got an update that crashed my entire rig, and I tried Hive one more time. Updated image and OS, and I was having the same problems. After searching on the web about my MOBO, I’ve found out that two people, on two different forums, were saying that this MOBO have a feature called TD-p, and disabling it solved all their problems.

Well, this setting was turned on on my mobo, so I’ve turned it off. And I also hadn’t any single crash since I’ve disabled it.

So, if you have this motherboard, and you are having problems, try this. Also, take a look at parsec’s reply on this forum to check for other possibilities: http://forum.asrock.com/forum_posts.asp?TID=6589&title=h110-pro-btc-cannot-boot-with-more-than-9-gpu

Hope this helps.

#2

Great tip. Thanks!

#3

where is the td-p option?

1 Like