Radeon VII Troubleshooting

#1

Has anyone successfully mined with Radeon VII on hive? If so, which build, drivers, and miner did you use? I’ve tried the standard build, the Vega build, and the bleeding edge build with phoenixminer and the card immediately jumps to 100 degrees Celsius and the miner stops to cooldown. Any help would be greatly appreciated. If you can help me resolve this, I’ll gladly send you 1 ETH✔️

#2

Nevermind I got it working. In fact, I have it running on hive with a p104, a 1080ti, and an RX570! Wild right?

#3

Try to reduce the voltage on the core to 1270 and apply down-volt in the firmware to a value of 875mv. If the temperature drops, then you can set a larger value at the core voltage.
All these recommendations are valid under the condition that the cards are new. Otherwise, high heat is possible due to the deterioration of thermal spacers on memory chips, or incorrect BIOS firmware

#4

Hi, can you please share how you managed to use Radeon VII ?
I’ve tried all hiveos variants and different AMD drivers, but unsuccesfull.
Thank you !

#5

I flashed the drive with the Vega image and then upgraded AMD drivers to 18.5. The problem I see is that either the drivers or hive are reading the junction temp and reporting it so it makes you think the card is running above 100 degrees

2 Likes
#6

Also, it’s notable that I went back after and ran ./amdgpu-pro-install command with the legacy parameter and this allows my rig to have both Radeon VII and RX cards.

1 Like
#7

Hello,

I have tried twice with the Vega image and it reads Radeon VII for all of them however it has red X
s and wont read temperatures and wont run any miners. It’s obviously the drivers, did you have this issue before you upgraded the drivers? How do you upgrade the drivers for AMD through the command? Thank you in advance, this has been driving me nuts.

#8

I did what you said (Vega image and updating to 18.5), but still having the exact same issues. Temperature jumps up instantly when mining starts and it auto stops. Obviously the wrong value. Also it says “Unknown memory”. If anyone can help I would really appreciate it.

Can’t really wait around for this to work so I may switch to Windows. If HiveOS supports Radeon VII in the future I will come back.

#9

As previously stated, I think the issue is that 18.5 driver reports junction temp (highest temperature of all 64 sensors) instead of the average.
I managed to get it to work by dropping core clock to 1500, core state 4, core voltage to 950, memory clock 1025. I believe I was able to do about 80 MH on Ethash with claymore but the fan was running at 100% and junction temp at about low-mid 70s. It, however, sounds like a FUCKING JET ENGINE taking off.
So I’m currently running:
Core 1300, DPM 4, V 850, Mem 1025 and -t -50 on claymore. The fan reports to be running at 60% and the temperature is table at 70 C. It produces at about 65 MH but at only a reported (not from wall) 135 watt. I haven’t had a lot of time to play with it so that’s the initial results (plus I’m new to this whole mining thing) but at least now my rig doesn’t sound like the LA airport.

#10

If it’s just the junction temp, then shouldn’t that be safe to let it run into 90-100 celsius and simply raise the critical temperature setting so it doesn’t shut off? I may give this another shot on hiveos then.

#11

Thanks for that info.
Soon we will get this Radeov VII work well and proper on Hive.

#12

I am really hoping so. I love Hive OS and want to keep my Radeon VII rig on it, but at the moment I am required to use MMPOS. Please fix the Radeon VII issue!

I also tried using all of the different versions (vega, bleeding edge, normal, etc.). Also tried the Crypto_Luigi install without luck. Even tried it on bleeding edge.

#13

Yeah I prefer Hive but am moving my rigs over to Smos until we get a working one

1 Like