Raven Ridge 2200g not showing gui / video output

I have installed Hive OS on my system. I am running a basic ryzen system (2200g on a MSI B350 PC Mate) I get video output in Windows and when booting into the hive menu. However once the GUI launches and starts hashing I get no output on my monitor. If I plug it into my gpu I can see output. It’s not a massive problem but it would be nice to get video out working on onboard.

To date I have done the following…
I have set IGPU to priority in my bios settings. I have tried multiple Hive OS installations. I can see the apu detected in my worker menu but is disabled. Does this have anything to do with it? I’m pretty new to Hive. I obviously don’t want to hash with my CPU if that meant enabling it. Thanks for any help you can provide.

Bump?

Hi Mythone.

Seems i have the same issue. Using MSI B450 Gaming Plus Max AMD Motherboard.

In BIOS i have set Primary Video Adapter to IGD. Initiate Graphic Adapter to IGD. Also changed Integrated Graphics from Auto to Forced. None of these seem to make a difference. I see the BIOS boot up on screen, but once Hive starts it switches to GPU.

I have updated Mobo BIOS also. This is my 2nd worker. I have another on Gigabyte Mobo see the worker log fine doesnt have this issue.

Be interested if you or anyone could find the fix. I will keep trying also. :slight_smile:

Cheers
Bill

I have an open ticket with the hive team. If there is any update or fix will post in here. Thanks glad to know it may be a more widespread issue here. I wonder if it is a particular driver missing for linux with raven ridge processors.

Hi Bill,

The gigabyte board, does it run a ryzen apu as well or different cpu? Wonder if it’s something MSI related.

No , my gigabyte worker has Intel CPU.

Sorry i should have also mentioned my MSI/Ryzen worker is AMD Picasso processor. Ryzen 3 3200G. but our motherboards sound very similar.

The other peculiar thing is CPU is showing disabled in Hive. I found another user had the same “Disabled” message when I searched “Picasso Disabled” that’s what prompted me to update mobo bios, but did not resolve disabled.

Neither issue prevents me from mining on GPU’s however so just another smaller issue, but may have some significance to the first issue.

Interesting. As mine is a raven ridge and shows in purple, almost like a gpu but is saying disabled as well…

Picaso GPU’s are disabled because they can be mined with but due to not having dedicated memory they are very slow and can cause instability, its a bit hard to find but there’s a brief mention of disabling Picaso GPU’s in the change log for 0.6-179@201206.

As a side note I tried mining with my 3400G and could get about about 3MH/s from it as I had 3200MHz memory running at 2933MHz and the dedicated memory set to 8GB in the BIOS but given DD4 RAM is considerably slower than…GDDR5/6 on graphics cards ts not a surprise the mining performance is low.

1 Like

I don’t want to mine on it. I simply want to get video output as I have it plugged into my onboard motherboard hdmi. Which doesn’t work when it gets past the hive boot screen.

Still no update yet on the support ticket regarding this issue. Bumping for visibility if anyone gets video output on an amd APU with a gpu installed (forcing igpu in bios) as soon as I get to hive boot menu I lose video out after console loads.

Hi there, So I have a fix. I ended up disabling uefi on my bios and choosing CSM. I then booted off the legacy option mode for my HIVEOS USB instead of the UEFI option as well and I have display on my APU.