Reported hashrate is LOWER than realtime and mean hashrates?

I’m having an odd issue where one of my rigs is reporting a lower hashrate than it is actually getting with the pool (HiveOS + Hiveon pool). See this screenshot: Screenshot by Lightshot

The realtime hashrate is around 150 MH/s, and the mean is rising because I added new cards to the rig yesterday, but it should stabilize here soon.

The weird part to me is that the reported hashrate is lower. I have three cards (3070, 3070, 5500 XT) mining at 65.65, 61.44, and 24.91 MH/s, respectively. The reported hashrate has been steady around 75 MH/s which is weird because it’s not like a single GPU isn’t reporting properly or something, since 75 isn’t the sum of any combination of the three cards.

I am aware that my profits are based on hashrate at the pool (which is doing fine), I am just curious as this isn’t a problem for my gaming PC (single 3080), which looks like this: Screenshot by Lightshot

Note that the mean is decreasing because I moved the two 3070s from it to the other rig.

Could be that miner is reporting wrongly. Which miner are you using? Is it indicative that reported is half of what it should be?

I found a solution on the Discord. The reason the reported rate is messed up is because I am using two miners: t-rex and teamredminer.

The fix was to use different worker names for each miner. So I appended my rig’s worker name with “-amd” for teamredminer and “-nvidia” for t-rex miner. Now the reported rates are accurate, but it is still slightly annoying to have to have an additional worker.

1 Like

can you show me how to do that?

You open up your worker on the Hive OS website, then go to Flight Sheets, and edit the flight sheet you’re currently using.

Then, you can click on “Setup Miner Config” for each of the miners that you’re using and add something like “-nvidia” or “-amd” to the end of your worker name.

1 Like

Lets say you are using 2 miners… for example T-rex and TTminer, in ONE of them, change
the default worker name, usually indicated by %WORKER_NAME% to something else… I like 007 myself, but you can type in say AmdCards, or what ever you wish. The pool tracks payment by your wallet address and worker name… once you make the change, you will see 2 workers and their total will show up against your wallet.

Cheers.

It’s not working for me :frowning:

Using T-rex for NVIDIA and Phoenix for AMD.

Trick is 2nd miner has to be unique. changing only the 1st miner does nothing. Also, append “-amd” or “-nvidia” to the end of worker name in lowercase only and no quote marks.

hello my friend i have the same problem but when i change the name in my first rig with the nvidia change and the amd rig so messy

any help please