RTX 2060 (TU106) and RTX 3070 (GA104) not detected

Hi, hope someone can help me with the following issue. I have a RTX3070 which is mining correctly. Though, when I added 3 new RTX2060, only one 2060 is detected and mines correctly. The remaining GPUs 2060 and 3070 are not detected at all in HiveOS.

Characteristics:

  • ASROCK Z590 PG Velocita P1.10
  • 1 to 4 PCIE Splitter adapter

What I tried:

  • Updated PCIE to GEN2/GEN3
  • Updated DMI Speed to GEN2/GEN3
  • Enabled - Auto 4G Decoding
  • Updated HiveOS
  • Updated NVIDIA drivers
  • Disabled CSM
  • Changed PCIE splitter adapter to other slots
  • Removed PCIE splitter and connected each GPU to riser and individual slots
  • Connected the PCIE Splitter to a different 16X

Also connected each GPU individually (via riser) without the others to see if they at least mine alone, and they do. So the issue is when they are connected altogether.
Also, connected only the 3 RTX 2060 without the RTX3070 but the issue persist, only one RTX2060 is detected.

The only thing I haven’t done is to update the MOBO, cause I’m not sure that will damage it.
What do you recommend? I’m going a bit crazy trying to get this worked out. Any suggestions are welcome.

Thanks,

Hi,
Connect your * 1 to 4 PCIE Splitter adapter to PCIx 16x

Hi Nanial,
Yes, I did that but did not work. :neutral_face:

Hi,
So the issue is when they are connected altogether… Two solution for this… Check your PSU for faulty … or something into bios on motherboard …

I updated the BIOS to the latest version, but the issue still occurs. :neutral_face: