RTX 3070 Not detected (GA104)

Hey I’m hoping someone here can help,
im having an issue where i had a stable setup running for about 15 hours or so before a random reboot during the night. Now one of the cards is showing as GA104 and it has no info about speed or temps on the webapp as you can see in the picture. iv tried reinstaling drivers with the maintenance mode on and off. i tried changing pcie ports as well. not sure what could be causing this issue. Any tips would be super helpful as i am very new to the whole mining thing.

just to add when i went in maintenance mode and rebooted with no drivers both cards appeared as GA104 as shown in the image below. After flashing the new drivers onto the cards the working one switches back to regular while the one that was having issues stays at GA104.

Execute from dashboard
nvtool -s
and check results

Execute from dashboard dmesg and look to loading Nvidia driver

Hey man I have the same problem.Did you solve it?

Hi @atasahinsa,
I also had the same problem.
My solution was a BIOS Update (special for Mining) and change the BIOS Settings.

Please check if there is a special mining BIOS for a motherboard. Be carefull with the BIOS Update, it could damage your System! If there is no BIOS Update, you have to check the BIOS settings.

Motherboard BIOS Settings For Mining | The Basics:
https://www.youtube.com/watch?v=XIT1f5nwHEw

1 Like

I had same problem and solved by MOBO bios update. And dont forget to change the PCI-e GEN-2 on bios settings.

facing the same with an AsRock Z490 on HiveOS4 rtx 3070 in rig, only the 1st one shows up normally and start mine with no problems, the other ones shows GA104 [GeForce RTX 3070], it lists like:
0- Geforce RTX 3070
1- GA104 [GeForce RTX 3070]
2- GA104 [GeForce RTX 3070]
3- GA104 [GeForce RTX 3070]

the gpu 0 is able to mine normally, all others dont, updated bios of mobo, updated HiveOS, updated drivers, changed bios settings (PCIE gen1 or 2 instead of auto, enabled 4g decoding and tried also disabled and many other bios settings), changed risers, slots, PSU.

the same setup with another mobo+proc works normally

1 Like

Hi
i have same problem
do you repaired this error?

Did you ever resolve this? I’m having the same exact problem.

Hi had same issue with Asrock motherboard and 3 3070. only the first one is mining. The other two won’t. Tested in Windows and all working fine. I am mining in Windows at moment.

Hello
I faced the same problem today.
I just replaced the riser and the problem went away.

I had this issue, what you have to do is…

  1. update mobo bios
  2. disable CSM (this was my main problem)
  3. enable 4g
  4. Gen1 or 2 or 3 can work

After experiencing the exact problem the OP was facing above I was able to get the Asrock z590 Phantom 4 working on HiveOS by disabling 4G encoding with 2 GPUs (3080 and 3060ti). I haven’t tried it with 3 or more but looking around at different forums it looks like it’s possible with Windows 10. Otherwise a new motherboard may be required.

had the same issue and a few hour a tring to figure this out I change the card that had the prodlem to a different PCIe slot and it worked.

once you insert the third gpu it enables automatically the 4g decoding then your problem starts back

Did a fresh install, all fixed on the first reboot and now mine at 40,5 MH / S https://forum.hiveos.farm/t/3070-not-being-recognized-by-hive-os/21532/11?u=stephenkleckner

SOLVED

For me at last.

I had the same issue with two RTX 3070, then after a lot of research and tests, I’ve come to a solution.

What I did:

  1. Updated my MOBO firmware to the latest
  2. Enabled 4G decoding
  3. Set PCI speed for GEN 2
  4. Disabled CSM
  5. Enable Resizable Bar

What made the difference was the item #5 (Enable Resizable Bar)

*All these settings were in MOBO BIOS

Hope it can help you guys

This is a basic error when building rigs with v2 LHR cards. Start by installing 470.74 and your problem is solved.