Rx 550


#181

@mobidev911
Надеюсь не задел ваши нежные чувства. 12шт 550 нормальный флот, если еще и по хорошей цене.
Я вообщем-то к чему что нормальной поддержки в драйверах (да-да именно с ними точнее забывчивостью в АМД включить OpenCL в драйверах) нет как для нижнего эшелона в лице RX 550 так и топовых RX Vega. А именно наличие OpenCL небходимо для майнинга. Пока драйверов хватает только для вывода картинки на десктопе в иксах.
Да сделав 22 притопа, 22 прихлопа и сказав ку мы получаем рабочий вариант, но уж очень как-то не очень, правда?

оффтоп:
Цена крипты на дно, а барыги пока отпускать цены не торопяться. Покупать карты по таким ценам себе дороже. Так уже было, только каждый раз период во времени растягивается.


#182

@HaloGenius понял, спасибо :slight_smile:

Да, цена эфира уже 460$, а барыги не спешат снижать цены на видеокарты. Но видно, что кое-где начали уже шевелится. Хотя цены все равно сильно завышены.


#183

Don’t know why I cannot make it successful by using amdgpu-pro-uninstall or apt autoremove. So I cannot install new drive and it always said /usr/bin/andgpu-Pro-uninstall : file exist

Sorry I am quite new on this and look forward to hearing any input.


#184

Ok… here a 100% Noob-Proof How-To :wink:

Based on a fresh Flashed HIVE

// Uninstall the GPU Driver…

  • We need to unpack the Driver an install it for a right Uninstall
    So we do:

[b]

cd /hive-drivers-pack
tar -Jxvf amdgpu-pro-17.50-511655.tar.xz
cd amdgpu-pro-17.50-511655
bash ./amdgpu-pro-install -y --compute
amdgpu-pro-uninstall

[/b]

Confirm with “y”…

// ok now REBOOT

[b]

reboot

[/b]

// after that

[b]

wget http://download.hiveos.farm/kernels/linux-headers-4.13.12-mytest_1_amd64.deb
wget http://download.hiveos.farm/kernels/linux-firmware-image-4.13.12-mytest_1_amd64.deb
wget http://download.hiveos.farm/kernels/linux-image-4.13.12-mytest_1_amd64.deb

[/b]

// And install it

[b]

dpkg -i linux-headers-4.13.12-mytest_1_amd64.deb
dpkg -i linux-firmware-image-4.13.12-mytest_1_amd64.deb
dpkg -i linux-image-4.13.12-mytest_1_amd64.deb

grub-set-default "1>0"; update-grub

[/b]

// ok… again… reboot

[b]

reboot

[/b]

// after that we install the working Driver, in my Case… the amdgpu-pro-17.40.2712-510357 works great for RX 550 560 570 580…

[b]

cd /hive-drivers-pack
wget --referer=http://support.amd.com https://www2.ati.com/drivers/linux/beta/ubuntu/amdgpu-pro-17.40.2712-510357.tar.xz
tar -Jxvf amdgpu-pro-17.40.2712-510357.tar.xz
cd amdgpu-pro-17.40.2712-510357
bash ./amdgpu-pro-install -y --compute

[/b]

// reboot an happy Mining… o.O

[b]

reboot

[/b]

Say thx 2:
ETN: etnjxU2vdq2UfQaBahApNrNSQuifB4JVXV5FK2HPp4TnbEv1xWh7QYfHYfprpRMgxMXQgv7wDwStmUcybVuVCnbY4fQu5WLDxn
ETH: 0x6dBfcE437fB8Ee49188e76560bb1A58Df5Ebb133
XUN: Xun3PHT9D4RiY75B5BMvnRdTeg6mtXjr7WZsvCkbeT98FLXyrGQW6rkBv1rJxPhGvpfFMiQMzxevxF419b7oKeun7HUqwmmCBR


#185

@Isnobad great tutorial, following it I have reached 480-490MH/s with my RX550 2GB (more than I could with Win 10).

But I have one issue, I cannot see GPU temp or fan speed anymore (before doing the changes here I had 400MH/s but the GPU was seen as RX560 and I could see temp and fan speed), the rig stats show as I have the GPU offline, and I have only CPU’s. What to do?

EDIT: I see now in agent-screen this error:
cat: ‘/sys/class/thermal/thermal_zone*/temp’: No such file or directory


#186

MH/s :wink:

mh, ok? “based on a fresh flashed Hive” ?
http://download.hiveos.farm/hive-0.5-32-20180228.zip

Maybe:

boot up Hive,
Stop Miner, (!)
Shutdown,
Boot (no miner active)
go SSH

apt update
apt upgrade
apt install lm-sensors
sensors-detect 

(y to all)

reboot

#187

my 550 was at 63.8 h/s, then I followed the guide, and it is way better, but still not as BLKro says. I cannot achieve anywhere near 400 h/s. What am I missing.?

hHASHRATE REPORT - CPU
| ID | 10s | 60s | 15m | ID | 10s | 60s | 15m |
| 0 | 56.8 | 56.3 | (na) | 1 | 58.1 | 57.6 | (na) |
| 2 | 58.0 | 57.5 | (na) |
Totals (CPU): 172.8 171.3 0.0 H/s

HASHRATE REPORT - AMD
| ID | 10s | 60s | 15m |
| 0 | 286.5 | 284.7 | (na) |
Totals (AMD): 286.5 284.7 0.0 H/s

Totals (ALL): 459.3 456.0 0.0 H/s
Highest: 459.9 H/s


#188


#189

@StarLog You have not read the whole thread, not even the first post if you are using Claymore Dual. You need to be using sgminer or xmr-stak with 2 threads per GPU. I for one am using xmr-stak with the following AMD config override:

“gpu_threads_conf” : [
// gpu: Baffin memory:1664
// compute units: 10
{ “index” : 0,
“intensity” : 432, “worksize” : 12,
“affine_to_cpu” : false, “strided_index” : true
},
{ “index” : 0,
“intensity” : 432, “worksize” : 12,
“affine_to_cpu” : false, “strided_index” : true
},
],

“platform_index” : 0,

For sgminer something like this should work (not tested myself):

“rawintensity”: “432”
“gpu-threads”: “2”
“worksize”: “12”


#190

@Isnobad I had a fresh install but went back and reformatted the usb stick and reinstalled from scratch, not it works, but I still see the GPU as RX560 although it is an RX550. At least now the temp is showing, and it’s been hashing away nicely for 3 days now, with 480H/s constantly (not MH/s :slight_smile: )


#191

@BLKro I am not sure how to change the screen to reflect xmr-stak. This is what I am getting after applying your config override.


xmr-stak 2.4.0 6feffe2

Brought to you by fireice_uk and psychocrypt under GPLv3.
Based on CPU mining code by wolf9466 (heavily optimized by fireice_uk).
Based on NVIDIA mining code by KlausT and psychocrypt.
Based on OpenCL mining code by wolf9466.

Configurable dev donation level is set to 2.0%

You can use following keys to display reports:
‘h’ - hashrate
‘r’ - results
‘c’ - connection

[2018-04-06 10:48:00] : Mining coin: monero7
WARNING: NVIDIA Unable to query number of CUDA devices!
[2018-04-06 10:48:00] : WARNING: backend NVIDIA disabled.
[2018-04-06 10:48:00] : Thread 0 has invalid config.

xmr-stak exited, waiting to cooldown a bit

How do I change the Custom Tuning from Claymore to xmr-stak.

I cannot change the wallet to get ride of claymore.

I cannot now attach another image to this thread so making a new response below


#192

This is for above comments.

So if I remove your override, the xmr-stak runs the miner, what am I missing in the override.?

Thanks for the help, this is my dev rig, once I get this working I will apply many more cards.


#193

Try changing platform_index from 0 to 1

Also to get rid of claymore is unnecessary, but you can do it by deleting every info from every box in the claymore tab… It is sufficient to select xmr-stak as miner in the rig options.


#194

Same thing after changing, and reboot…

“gpu_threads_conf” : [
// gpu: Baffin memory:1664
// compute units: 10
{ “index” : 0,
“intensity” : 432, “worksize” : 12,
“affine_to_cpu” : false, “strided_index” : true
},
{ “index” : 0,
“intensity” : 432, “worksize” : 12,
“affine_to_cpu” : false, “strided_index” : true
},
],

“platform_index” : 1,

xmr-stak 2.4.0 6feffe2

Brought to you by fireice_uk and psychocrypt under GPLv3.
Based on CPU mining code by wolf9466 (heavily optimized by fireice_uk).
Based on NVIDIA mining code by KlausT and psychocrypt.
Based on OpenCL mining code by wolf9466.

Configurable dev donation level is set to 2.0%

You can use following keys to display reports:
‘h’ - hashrate
‘r’ - results
‘c’ - connection

[2018-04-06 17:47:17] : Mining coin: monero7
WARNING: NVIDIA Unable to query number of CUDA devices!
[2018-04-06 17:47:17] : WARNING: backend NVIDIA disabled.
[2018-04-06 17:47:17] : Thread 0 has invalid config.

xmr-stak exited, waiting to cooldown a bit


#195

Looks like you’re on the new xmr-stak, try this:

“gpu_threads_conf” : [
{ “index” : 0, “intensity” : 432, “worksize” : 12, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 1,
“comp_mode” : true },
{ “index” : 0, “intensity” : 432, “worksize” : 12, “affine_to_cpu” : false, “strided_index” : 1, “mem_chunk” : 1,
“comp_mode” : true },
],
“platform_index” : 0,


#196

but also update to the latest hiveos which should have xmr-stak 2.4.2 (.0 and .1 are buggy)


#197

Well, it atleast liked the config. Not sure if I am getting the max…
Only getting 142 h/s on the GPU, not anywhere near yours.

HASHRATE REPORT - CPU
| ID | 10s | 60s | 15m | ID | 10s | 60s | 15m |
| 0 | 56.5 | (na) | (na) | 1 | 57.8 | (na) | (na) |
| 2 | 57.7 | (na) | (na) |
Totals (CPU): 171.9 0.0 0.0 H/s

HASHRATE REPORT - AMD
| ID | 10s | 60s | 15m | ID | 10s | 60s | 15m |
| 0 | 138.1 | (na) | (na) | 1 | 139.0 | (na) | (na) |
Totals (AMD): 277.1 0.0 0.0 H/s

Totals (ALL): 449.0 0.0 0.0 H/s
Highest: 0.0 H/s


#198


#199

When I download the vbios, where is it stored.? I cannot find it.


#200

I think you need to mod the bios for the higher hashrates. At least mine are modded, don’t have an unmodded one to compare to your’s.

After you click download vbios, click reload up top after a few minutes and you should see this:

Click to save the file to disk.