RX 5700 XT - drivers and PhoenixMiner

Hello,
note: I have XT version (or RX5700)

I guess that many asks for this, but Ive tried those:

  • HiveOS stable / beta / vega …
  • AMD driver 19.20,19.30, 19.50 …

but I was unable to make it working.
Therefor Im asking for working combo. Like:

  • what HiveOS image should I use? (someone is suggesting: (kernel 5.0.21-hiveos-beta with AMD drivers 19.30).

  • is this image for ALL version of XT or some version are not supported?

  • driver? Should I use those at image, OpenCL, oficial, from installer, which version?

  • miner (for ETH): Phoenix 5.0? That should be fine, but I couldnt make it working coz drivers issue.

  • OC. Any tips there? vlt / mem / core / fan … temperature limit?

I got RX 5700 XT xx-xx-xxxx, or even with memory details, but miner didnt started there (Phoenix, EthMiner). amd-info returns details.

Hi,

Do you use any PCI-e spliter ?
What MB are you using ?

No PCIe splitters. Each of 6 card goes directly to MB.

Motherboard: H110-D3A-CF Gigabyte Technology Co., Ltd. (F25 04/11/2018)
CPU: 2 × Intel(R) Celeron(R) CPU G3930 @ 2.90GHz AES
Disk Model: ATA Corsair Force LS 60.0GB

how do you upgrade driver inside os ? a new driver for ubuntu is out…

I tried 19.30, 19.50, 20.10 drivers.
Installed with amd_install.sh (script from forum), and also directly with official amd installer (as amdgpu, amdgpu-pro, pal,legacy, headless, …). Yeap, nothing. There for Im asking (and Im not alone as I can see).

How … uninstall, stop:

amdgpu-uninstall -y
amdgpu-pro-uninstall -y
systemctl stop hivex
killall xinit
miner stop

Then install (this is eg 20.10):

cd amdgpu-pro-20.10-1048554-ubuntu-18.04
./amdgpu-pro-install -y
dpkg -l amdgpu-pro

i  amdgpu-pro                       20.10-1048554         amd64                 Meta package to install amdgpu Pro components.

… installed, not working.

im having a similar issue on one of rx 5700 rigs but the other 2 are good with 19.30 drivers but i cant seem to get the 19.50 drivers working on any rx 5700(xt) rig
To get the other rigs to work I did a fresh usb with the beta hiveos image but i still get a bunch of powerplay errors in the console although they seem to be mining fine with no incorrect shares

Try the beta image again, I had the same issue but the beta image worked fine.

Reinstall amdgpu-pro packages with OpenCL: https://amdgpu-install.readthedocs.io/en/latest/install-installing.html#installing-the-pro-variant

Hello, well I did tried that already (Jun 22 post).
$ ./amdgpu-pro-install -y --opencl=pal,legacy
$ ./amdgpu-pro-install -y --opencl=pal,legacy --headless

And also default:
$ ./amdgpu-pro-install -y

So, all 3 variants.

1 Like

Hi, I had the same situation.

I was able to run 2 stable rigs using:

Kernel: 5.0.21-hiveos-beta
Driver: A 19.30

I wasn’t lucky with otther kernel version nor driver.

Hope this help!

Regards.

I can mine with Claymore/Phoenixminer/Etherminer/ …

Kernel: 5.6.0-200909-hiveos-beta

AMD Driver: OpenCL 19.30

Nvidia: 440.100

GTX 1660 × 2·

RX 5700 × 5

I hope that info help…

using hiveos-0.6-156@200905.iso it did not work and HiveOS displayed:
-Radeon RX 5700 XT
-unknown GDDR6 memory

i used a new USB stick and installed hiveos-beta-0.6-157@200909.img Hive os now reads:

-Radeon RX 5700 XT 8176 MB · MSI
-Samsung GDDR6 113-MSITV381MH.190
-Hashrate ETH 49.37 out of the box. 183Watt Temp 59, memory temp 92.

I wonder why the temperature shows 92. I don’t see that reading in my RX570 cards anyways.

I hope it helps.

Same problem, nothing above doesn’t work. In RaveOS rig works from a scratch, Good luck with your project

Gecon i had same problem with you.
i was tried so many ways for fix this.
finally i can fix it.
i want to know just about your computer spec.
cpu / ram / main board / expand card version / hiveos version / amd driver version.
in my case it matter of main memory.
if you can raise your RAM capacity, you can also solve this problem.
my miner had only 8GB Main memory. so i was raise to 16GB.
it is my solution.
plz try this for your happy mining.

After alot of trial and error, i was successful with the following:

  1. Increased computer ram from 4GB to 8GB
  2. Downloaded the beta version without modifying any drivers

The installed drivers in the beta version was OpenCL 19.30

1 note compared to windows. The system requires 50 more core clock to run at same hashrate as windows. in my case, i had to increase core voltage also by 50

i was running 1300/750/1800 in windows for 55.5 Mh/s, i am running 1350/800/900 in HiveOS to get the same hashrate.

that´s why I want to try to update driver in hiveOS…I hope I can get same result for mhash as I had in windows. I had to increase too…I try this weekend…one question for the maintenance mode. when I want to uninstall drivers and install new ones…do I boot to maintenance mode with loading drivers or without loading drivers???

1 Like

I have 5.6 kernal, how do I downgrade to 5.0.21-hiveos-beta kernal?

Hive-replace --list
Look for beta2