RX 6600 XT - card not deteced correctly

Hey Guys,

Hive is not detecting my RX 6600 XT correctly. From what i have seen on others getting this to work is that they have a nother Kernal installed. Could that be it?

I have 5.4.0-hiveos #132 and i cant find any information on how to update it. The weird thing is that i used the Hive OS installer for this. Or is this the latest Kernal?

I have tried to downgrade and upgrade to a ton of different OS versions but with no luck. Getting kind a desperate here :slight_smile:

Thanks in advance

you have to do a clean install of a newer hive version, you can either download the image from hive and reflash, or open the shell (witrh shellinabox/hive shell/locally) and type hive-replace -s

once that finishes youll be off to the races.

1 Like

Thank you Keaton! It worked perfectly.

Stay safe and happy mining!

1 Like

If i do a hive-replace -s do i loose my oc settings and flight sheets ? I have the exact same problem. Also my hive is on ssd not usb.

Nope, all of that info is stored on hives servers.

1 Like

I cant make it work, i did the hive-replace -s and still nothing. I moved it from riser to slot still the same, on my PC/win10 works fine.

either you didnt do hive-replace, or you didnt let it finish, youre still on the old kernel which hive-replace would replace

1 Like

Yep something was happening, after the archive check it started stopping services and the remote shell in box would die too… and i would do a hard reset(because nothing worked). This morning i connected a monitor and keyboard, and for some reason in didn’t die and actually completed the process. And now the card is working. So thanks a lot for your time and help.

1 Like

no problem, glad to hear its working now!

1 Like

helo, i have kinda same situation but… currently my mining rig is mixed
gpu 0 gtx 1070
gpu 0 rx 580
gpu 1 1660

but when i add 1 more gpu which is 6600 xt, the 6600 xt wont display/not detected
either in worker, only show 3 gpu only…
any solution please ?

did you do what was said above?

hello, i need help. I have 3 6600 xts and 1 6600. I can only get one GPU working, and the other gpus say “failed to init”. I downloaded hiveos on an SSD five times already, used hive-replace. The card brands are recognized but the memory is unknown.

Verify your bios settings are optimal for mining.

Hi keaton, I am running hive OS from an SSD. I totaly understand how I have to do a clean install with balena etcher. But how do I make a replacemnet? I am using my laptop for remote access, but hive needs to get updated on the ssd that is connected to my rig?! when I enter “hive-replace -s” on my laptop I do receive the hint, that all data will be removed from sda … so does that warning referes to the ssd of the rig?
might be really a stupid question…I am just starting
thanks in advance, Horst

Hi keaton, so I just finished the hive-replacement -s … my Sapphire RX 6600 XT does not show up! What’s the problem?

… the LED of the riser of the 6600 XT is on and the card itself shows all it rainbow-colors … but fans are not turning :frowning:

if the card isnt showing up at all, its likely not a hive issue. try the card on the motherboard directly and verify it works

I booted the rig today … the 6600XT is there and is mining! Don’t know what it was … but everthing is fine now. Thank you keaton!

1 Like

Hi keaton, now that the 6600XT is running, I tried to add the oder Sapphire 580 8 GB. Now this 580 only shows 16-17 mhs, before the 6600XT I had 28 mhs.
I did set all the oc from all card to “0”. Still the 580 does not show numbers around 26-28mhs, only 16-17.
What’s the reason and what can I do?
Thanks in advance

the cards mine on windows but it doesn’t detect on hiveos, I have tried every possible bios settings. Is there anything else I can try, my motherboard is an asrock h570 phantom gaming 4.