RX570 x 5 gpu's - AMD settings applied with errors - I keep seeing this after the latest update on HiveOS

#1

Hey there,

I have updated to latest HiveOS and now I am getting this error each time I restart the miner: “AMD settings applied with errors”
Not sure how to debug this, and what is causing the errors. I have to say prior to update I didn’t had these errors.

If anyone knows how to debug it … I have searched the form but I couldn’t find a solution. Some of the users said that the risers were the problem. But I don’t know if that is the case for me.

Thank you!

Sun Jul 15 21:41:45 EEST 2018

Detected 5 AMD cards
CORE_CLOCK = 1150 1150 1150 1150 1150
CORE_STATE = 2 2 2 2 2
CORE_VDDC = 850 870 870 850 870
MEM_CLOCK = 2060 2000 2000 2060 2000
MEM_STATE =
FAN =

=== GPU 0, 01:00.0 /sys/class/drm/card1 ===
wolfamdctrl -i 1 --mem-clock 2060 --mem-state 2 --core-clock 1150 --core-state 2 --vddc-table-set 850 --volt-state 2
Memory state 2 clock: 1750 -> 2060.
DPM state 2 core clock: 952 -> 1150.
Voltage table index 2: 65283 -> 850.
Setting DPM core state to 2

=== GPU 1, 03:00.0 /sys/class/drm/card2 ===
wolfamdctrl -i 2 --mem-clock 2000 --mem-state 2 --core-clock 1150 --core-state 2 --vddc-table-set 870 --volt-state 2
Memory state 2 clock: 1750 -> 2000.
DPM state 2 core clock: 994 -> 1150.
Voltage table index 2: 65283 -> 870.
Setting DPM core state to 2

=== GPU 2, 04:00.0 /sys/class/drm/card3 ===
wolfamdctrl -i 3 --mem-clock 2000 --mem-state 2 --core-clock 1150 --core-state 2 --vddc-table-set 870 --volt-state 2
Memory state 2 clock: 1750 -> 2000.
DPM state 2 core clock: 994 -> 1150.
Voltage table index 2: 65283 -> 870.
Setting DPM core state to 2

=== GPU 3, 05:00.0 /sys/class/drm/card4 ===
wolfamdctrl -i 4 --mem-clock 2060 --mem-state 2 --core-clock 1150 --core-state 2 --vddc-table-set 850 --volt-state 2
Memory state 2 clock: 1750 -> 2060.
DPM state 2 core clock: 952 -> 1150.
Voltage table index 2: 65283 -> 850.
Setting DPM core state to 2

=== GPU 4, 07:00.0 /sys/class/drm/card5 ===
wolfamdctrl -i 5 --mem-clock 2000 --mem-state 2 --core-clock 1150 --core-state 2 --vddc-table-set 870 --volt-state 2
Memory state 2 clock: 1750 -> 2000.
DPM state 2 core clock: 994 -> 1150.
Voltage table index 2: 65283 -> 870.
Setting DPM core state to 2

#2

870mV - invalid voltage

valid 850, 862, 875, 887, 900 and so on

#3

I know… i had before 850 and got the same erros. I have also tried with 900.

AMD settings applied with errors

#4

This is news to me. How do these steps of voltage work? and where can I find all valid voltages?

#5

it’s digital world )
One step aprox 12.5mV
So starting from 800 mV you can continue a series of numbers without floats
For example:
800 + 12.5 = 812.5 -> 812
(812.5) + 12.5 = 825
825 + 12.5 = 837.5 -> 837
(837.5) + 12.5 = 850
and so on
In above example we got series 800 812 825 837 850

1 Like
#7

please add this voltage list somewhere here:

Screenshot_2018-08-09_18-37-46