Sapphire rx570 (Samsung) 0.0mh/s

Hi, first time post here, hoping someone can help. I have a sapphire rx570 8gb with Samsung memory, and I’m having trouble getting it to hash at all.
Phoenix miner show’s 0.0mh/s
Teamred miner show’s ‘gpu dead’ error
I’ve tried different OC settings, from normal to conservative (have 2 other Samsung Rx cards and both are very sensitive to OC)
But can’t get it to work. I would’ve thought if it was genuinely dead then it probably wouldn’t show up in HiveOS?
Am I wasting time on a dead card, or am I missing something?
Thanks

show us the OC settings

It does the same with any OC I tried. I normally start around 1100 core, 850mv, core state 2, 2200 mem clock. Then work around from there depending on how the card reacts.
With this one I tried adjusting every parameter but still refuses to hash. Normally I would expect either a low hashrate or a crash, but I’m just getting nothing with this one.

Put it on another machine and check if start …

Ok, I’ll try on another rig and see what happens

Lower memory clock to ~2050mhz and see if it works. 2200mhz is too much with stock voltage.

ok, I got this card out again to give it another try. On a different rig this time. Now I’m getting wildly inaccurate hashrate, into the gigahash range. It’s acting as if it’s mining, but then miner restarts


(gpu1 in this image)

tried bios flash with original bios, modded bios, and different versions of bios, and seem to get the same issue.

anybody have any advice on where to go from here?