Setting up HiveOS with Awesome Miner

awesome-miner
listen-parameter
api-enabled
hive-api
#1

Hopefully someone can guide me. . . . . I have awesome miner and i’m trying to add my Rig that is running hiveOS onto it. When i go to add External Rig and i type in the relevant information (IP address, algo, software) and try to add it i get the error "failed to connect, please ensure that the correct hostname and optionally port has been entered. please also check that the mining software is running with the API enabled. I cannot figure out how to get this to work. Any help greatly appreciated.

#2

u want to monitor or to control?

#3

just monitor . … control would be nice but at this point i just want to get it to work lol.

#4

So the help desk from awesome miner got back to me today. they said:

For DSTM, you need to add a flag like this, and then let Awesome Miner connect on the specified port
–telemetry=0.0.0.0:2222

I don’t know the details of how this is configured on HiveOS, but the command line above is what is required.

How do i go about adding this line to hiveOS?

#5

I set my rigs up as External Miners. Enter the IP and click Test connection and they worked.

I have status update set to 5 seconds. I left Algorithm to Unspecified and changed Software to Claymore’s Dual Ethereum Miner AMD/nVidia.

What settings are you trying?

#6

Monitor for Monitor )))
Hmmmm how intrasting :smiley: :smiley: :smiley:

#7

@josephfranco I found this post and thought it might help https://bitcointalk.org/index.php?topic=2350786.msg30766873#msg30766873

He added it to the Tuning section.

#8

Yeah it works just fine with Awesome miner , with AM U can also watch GPU Core Clocks & Mem Speed info… For B miner add -api 0.0.0.0:1880 Tried different ports , It seems that b/c the default API is on :1880 U have to use port 1880 for Bminer. Hope it helps.