Sgminer-gm cryptonigth

etn-electroneum-cryp
#1

Добрый день!
Не полуачется запусить sgminer-gm на electroneun, вылетает по seg fault.

Кто-нибудь запускал?

[2018-01-09 13:15:48] Started sgminer 5.5.5-gm-a
[2018-01-09 13:15:48] * using Jansson 2.7./sgminer-gm.sh: line 23: 28602 Segmentation fault ./$binary -c sgminer-gm.conf

{
“temp-target”: “68”,
“temp-cutoff”: “80”,
“temp-overheat”: “82”,
“auto-fan”: true,
“log-file”: “sgminer-gm.log”,
“log-show-date”: true,
“text-only”: false,
“verbose”: true,
“debug”: true,
“per-device-stats”: true,
“log”: “15”,
“api-listen”: true,
“api-port”: 4028,
“user”: “wallet.id.rig/e-mail”,
“url”: “stratum+tcp://etn-eu1.nanopool.org:13333”,
“pass”: “x”,
“algorithm”: “cryptonight”,
“_lazyend”: “”
}

[2018-01-09 13:13:38] Log date is now 2018-01-09
[2018-01-09 13:13:38] Set default algorithm to cryptonight
[2018-01-09 13:13:38] Started sgminer 5.5.5-gm-a
[2018-01-09 13:13:38] * using Jansson 2.7
[2018-01-09 13:13:38] Loaded configuration file sgminer-gm.conf
[2018-01-09 13:13:38] CL Platform vendor: Advanced Micro Devices, Inc.
[2018-01-09 13:13:38] CL Platform name: AMD Accelerated Parallel Processing
[2018-01-09 13:13:38] CL Platform version: OpenCL 2.0 AMD-APP (2482.3)
[2018-01-09 13:13:38] Platform devices: 8
[2018-01-09 13:13:38] 0 Ellesmere
[2018-01-09 13:13:38] GPU0: detected PCIe topology 0000:03:00.0
[2018-01-09 13:13:38] 1 Ellesmere
[2018-01-09 13:13:38] GPU1: detected PCIe topology 0000:04:00.0
[2018-01-09 13:13:38] 2 Ellesmere
[2018-01-09 13:13:38] GPU2: detected PCIe topology 0000:05:00.0
[2018-01-09 13:13:38] 3 Ellesmere
[2018-01-09 13:13:38] GPU3: detected PCIe topology 0000:06:00.0
[2018-01-09 13:13:38] 4 Ellesmere
[2018-01-09 13:13:38] GPU4: detected PCIe topology 0000:08:00.0
[2018-01-09 13:13:38] 5 Ellesmere
[2018-01-09 13:13:38] GPU5: detected PCIe topology 0000:0b:00.0
[2018-01-09 13:13:38] 6 Ellesmere
[2018-01-09 13:13:38] GPU6: detected PCIe topology 0000:0c:00.0
[2018-01-09 13:13:38] 7 Ellesmere
[2018-01-09 13:13:38] GPU7: detected PCIe topology 0000:0d:00.0
[2018-01-09 13:13:38] Default Devices = all
[2018-01-09 13:13:38] set_devices(all)
[2018-01-09 13:13:38] Loading settings from default_profile for pool 0
[2018-01-09 13:13:38] Pool 0 Algorithm set to “cryptonight”
[2018-01-09 13:13:38] Pool 0 devices set to “all”
[2018-01-09 13:13:38] Pool 0 lookup gap set to “(null)”
[2018-01-09 13:13:38] Pool 0 Intensity set to “8”
[2018-01-09 13:13:38] Pool 0 Thread Concurrency set to “(null)”
[2018-01-09 13:13:38] Pool 0 GPU Clock set to “(null)”
[2018-01-09 13:13:38] Pool 0 GPU Memory clock set to “(null)”
[2018-01-09 13:13:38] Pool 0 GPU Threads set to “(null)”
[2018-01-09 13:13:38] Pool 0 GPU Fan set to “(null)”
[2018-01-09 13:13:38] Pool 0 GPU Powertune set to “(null)”
[2018-01-09 13:13:38] Pool 0 GPU Vddc set to “(null)”
[2018-01-09 13:13:38] Pool 0 Shaders set to “(null)”
[2018-01-09 13:13:38] Pool 0 Worksize set to “(null)”
[2018-01-09 13:13:38] Trying to set current pool…
[2018-01-09 13:13:38] Probing for an alive pool
[2018-01-09 13:13:38] Testing etn-eu1.nanopool.org
[2018-01-09 13:13:38] Succeeded delayed connect
[2018-01-09 13:13:38] XMR AuthID: 1
[2018-01-09 13:13:38] parse_notify_cn()
[2018-01-09 13:13:38] Stratum authorisation success for etn-eu1.nanopool.org
[2018-01-09 13:13:38] [THR0] gen_stratum_work_cn() - algorithm = cryptonight
[2018-01-09 13:13:38] gen_stratum_work_cn() done.
[2018-01-09 13:13:38] [THR0] Pushing work from etn-eu1.nanopool.org to hash queue
[2018-01-09 13:13:38] New block: a332f7d7b9e8597dfdc89427f9ef3885583c02a4212aeaf215d1a251d2d205ae… diff 120K
[2018-01-09 13:13:38] Trying to set current pool…
[2018-01-09 13:13:38] etn-eu1.nanopool.org alive
[2018-01-09 13:13:38] Trying to set current pool…
[2018-01-09 13:13:38] Startup GPU initialization… Using settings from pool etn-eu1.nanopool.org.
[2018-01-09 13:13:38] Startup Pool No = 0
[2018-01-09 13:13:38] compare_pool_settings()
[2018-01-09 13:13:38] set_devices(all)
[2018-01-09 13:13:38] Switching to intensity: pool = 8, default =
[2018-01-09 13:13:38] intensity -> 8
[2018-01-09 13:13:38] Set GPU 0 to cryptonight
[2018-01-09 13:13:38] Set GPU 1 to cryptonight
[2018-01-09 13:13:38] Set GPU 2 to cryptonight
[2018-01-09 13:13:38] Set GPU 3 to cryptonight
[2018-01-09 13:13:38] Set GPU 4 to cryptonight
[2018-01-09 13:13:38] Set GPU 5 to cryptonight
[2018-01-09 13:13:38] Set GPU 6 to cryptonight
[2018-01-09 13:13:38] Set GPU 7 to cryptonight
[2018-01-09 13:13:38] Allocate new threads…
[2018-01-09 13:13:38] Assign threads for device 0
[2018-01-09 13:13:38] Thread 0 set pool = 0 (etn-eu1.nanopool.org)
[2018-01-09 13:13:38] Init GPU thread 0 GPU 0 virtual GPU 0
[2018-01-09 13:13:38] CL Platform vendor: Advanced Micro Devices, Inc.
[2018-01-09 13:13:38] CL Platform name: AMD Accelerated Parallel Processing
[2018-01-09 13:13:38] CL Platform version: OpenCL 2.0 AMD-APP (2482.3)
[2018-01-09 13:13:38] Platform devices: 8
[2018-01-09 13:13:38] 0 Ellesmere
[2018-01-09 13:13:38] GPU0: detected PCIe topology 0000:03:00.0
[2018-01-09 13:13:38] 1 Ellesmere
[2018-01-09 13:13:38] GPU1: detected PCIe topology 0000:04:00.0
[2018-01-09 13:13:38] 2 Ellesmere
[2018-01-09 13:13:38] GPU2: detected PCIe topology 0000:05:00.0
[2018-01-09 13:13:38] 3 Ellesmere
[2018-01-09 13:13:38] GPU3: detected PCIe topology 0000:06:00.0
[2018-01-09 13:13:38] 4 Ellesmere
[2018-01-09 13:13:38] GPU4: detected PCIe topology 0000:08:00.0
[2018-01-09 13:13:38] 5 Ellesmere
[2018-01-09 13:13:38] GPU5: detected PCIe topology 0000:0b:00.0
[2018-01-09 13:13:38] 6 Ellesmere
[2018-01-09 13:13:38] GPU6: detected PCIe topology 0000:0c:00.0
[2018-01-09 13:13:38] 7 Ellesmere
[2018-01-09 13:13:38] GPU7: detected PCIe topology 0000:0d:00.0
[2018-01-09 13:13:38] List of devices:
[2018-01-09 13:13:38] 0 Ellesmere
[2018-01-09 13:13:38] 1 Ellesmere
[2018-01-09 13:13:38] 2 Ellesmere
[2018-01-09 13:13:38] 3 Ellesmere
[2018-01-09 13:13:38] 4 Ellesmere
[2018-01-09 13:13:38] 5 Ellesmere
[2018-01-09 13:13:38] 6 Ellesmere
[2018-01-09 13:13:38] 7 Ellesmere
[2018-01-09 13:13:38] Selected 0: Ellesmere
[2018-01-09 13:13:38] Preferred vector width reported 1
[2018-01-09 13:13:38] Max work group size reported 256
[2018-01-09 13:13:38] Maximum work size for this GPU (0) is 256.
[2018-01-09 13:13:38] Your GPU (#0) has 32 compute units, and all AMD cards in the 7 series or newer (GCN cards) have 64 shaders per compute unit - this means it has 2048 shaders.
[2018-01-09 13:13:38] Max mem alloc size is 4020240384
[2018-01-09 13:13:38] Using source file cryptonight.cl
[2018-01-09 13:13:38] GPU 0: selecting lookup gap of 2
[2018-01-09 13:13:38] GPU 0: selecting thread concurrency of 30592
[2018-01-09 13:13:38] Setting worksize to 256
[2018-01-09 13:13:38] Using binary file cryptonightEllesmeregw256l8.bin
[2018-01-09 13:13:38] No binary found, generating from source
[2018-01-09 13:13:38] Building binary cryptonightEllesmeregw256l8.bin
[2018-01-09 13:13:38] Trying to open /usr/local/bin/cryptonight.cl…
[2018-01-09 13:13:38] Trying to open ./cryptonight.cl…
[2018-01-09 13:13:38] Trying to open ./kernel/cryptonight.cl…
[2018-01-09 13:13:38] Using ./kernel/cryptonight.cl
[2018-01-09 13:13:38] CompilerOptions: -I “.” -I “./kernel” -I “.” -D WORKSIZE=256 -I “/usr/local/bin”

#2

Запускается, только если в настройках кошелька в Extra config arguments указать:
“rawintensity”: “1024”
“worksize”: “8”
“gpu-threads”: “1”
Но почему-то хешрейт очень низкий по сравнению с клеймором, сижу на клейморе.

#3

Когда я попробовал хайв первый раз, то был только сгмайнер найса и сгмайнер 5.5.5 гм, но с какой-то припиской а… в вендовской версии этой приписке не было. Из этих двух работал только найсовский, но хешрейт у него был ниже, чем у клеймора. обычный вообще не стартовал.

Прилетела обнова - 0,5,22 - там аж 4 версии появилось, заработал таки обычный 5.5.5-гм-а, пропал у меня куда-то найсовский, добавился гейтлесс и пфи. Ну так вот, при общей настройке:
“rawintensity”: “420”
“worksize”: “8”
“gpu-threads”: “2”
риг на 5х460 выдаёт по 380…410 хешей на карту, хотя в виндовской версии этот же риг жмёт по 490…510 хешей с карты, в зависимости от скорости памяти. Здесь же разгон везде одинаков и… он умудряется ещё разный хешрейт по картам выдавать, не говоря уже о том, что не дотягивает до клеймора - 460…470. Гейтлес ведёт себя так же…

Какими параметрами должна обладть система, чтобы она смогла в сгмайнере в хайве выдавать мои привычные 2450…2500 хешей с 5 карт. Сейчас только 2350 только получается…

#4

Когда я попробовал хайв первый раз, то был только сгмайнер найса и сгмайнер 5.5.5 гм, но с какой-то припиской а… в вендовской версии этой приписке не было. Из этих двух работал только найсовский, но хешрейт у него был ниже, чем у клеймора. обычный вообще не стартовал.

Прилетела обнова - 0,5,22 - там аж 4 версии появилось, заработал таки обычный 5.5.5-гм-а, пропал у меня куда-то найсовский, добавился гейтлесс и пфи. Ну так вот, при общей настройке:
“rawintensity”: “420”
“worksize”: “8”
“gpu-threads”: “2”
риг на 5х460 выдаёт по 380…410 хешей на карту, хотя в виндовской версии этот же риг жмёт по 490…510 хешей с карты, в зависимости от скорости памяти. Здесь же разгон везде одинаков и… он умудряется ещё разный хешрейт по картам выдавать, не говоря уже о том, что не дотягивает до клеймора - 460…470. Гейтлес ведёт себя так же…

Какими параметрами должна обладть система, чтобы она смогла в сгмайнере в хайве выдавать мои привычные 2450…2500 хешей с 5 карт. Сейчас только 2350 только получается…