Team red miner fails to start when using hive overclock settings RX580 8GB

hi all,

I’m hoping someone can help. My other rigs all running nice with nvidia cards & trex via hiveos. I’ve transferred another rig today from msos to hive which has 6x RX580 cards.

The issue i’m having is that once i have applied my card overclocks in hive ; team red miner would never start mining. I can see trm running if i console to the rig and use command miner but it doesn’t even seem to have acknowledged GPU’s or loaded even the DAG file.

Once i remove all overclocks to the cards and then restart the rig trm will start fine on all cards and the cards will start hashing. At this point I can apply the overclocks no problem and my hashrate per card jumps up to where it should be ( around 32mh ) & the power is reduced by about 25W per card which again is as expected.

Why wont TRM start normally with my Hive overcock settings within the worker / flightsheet from boot or restart ?? Its quite annoying to be honest and can’t really find any info whilst doing the usual googling.

thx in advance for any of you that can help.

worth noting my settings : -

System type

linux

Kernel

5.4.0-hiveos #108
Team red miner is latest version ( although i’ve tried 2 prior to this with same result )
AMD driver is 20.40

Hi,
Try this …under settings …look for miner delay…settings miner delay


This apply OC settings before miner starts…

trm config
–watchdog_disabled

Hi Nanial, thx for your reply. My issue is that “IF” i have any overclocks applied through HIVE prior to Teamredminer starting then teamredminer won’t start hashing at all. It will just sit with a blank screen within console with no logged events even occuring. It doesn’t even do the usual identifying the GPU’s present. So your solution will not cure the problem with this miner and hiveos. If i start Teamredminer without any overclocks applied through Hive and then after the miner has started hashing “THEN” apply the overclos through hive everything is ok and hashrates increase to reflect the overclocked card value. When using nvidia cards Hiveos have built in the option to miners such as Trex miner which states apply overclocking profiles after ??? seconds ; you input your value in seconds to this setup and all works lovely with no issues. There is no option like this available with teamredminer and hiveos.

If i use teamredminer standalone with a batch file it obviously works as it should as there are no card overclocks set.

Hi Smining570 thx for your reply , trm config -watchdog_disabled is kind of counter intuitive isn’t it ? We want our rigs to be stable etc and i see the watchdog in TRM to be a valuable thing to have keeping an eye on things. Are you saying that with watchdog disabled TRM starts hashing without issue when cards are overclocked within Hive ???

Other thing i’ve noticed with TRM is that i set my rx580’s undervolt to .850 yet TRM in console reports the undervolt to be 0.950. Again this is pretty strange and not allowing me to get the best hash/watt ratios for these cards not to mention try and increase there lifecyle etc.

Surely TRM with 1% dev fees from the community can develop simple arguments in config for a future release which would allow HIve or any other mining software overclocks to apply after ??? seconds of miner starting or a workaround on the watchdog that it only starts monitoring after so many seconds from connecting to a pool and hashing.

Your thoughts and any other sensible suggestions to sort my and probably others issues. TRM is super stable for me with AMD cards so it would be a shame to move my small 5GH to another miner such as lolminer. I’ve always had nvidia cards up until recently where stock has run dry in the UK to expand my farm lol

thx in advance

tony

for me, that config eliminates dead gpu error, there is other cofigs in trm manual that are related to this same issue. im with hive watchdog, i know it monitors only hash/algo, but i belive that there is something wrong with trm watchdog atm, before i could start my (even smaller rig with650mh) just fine with my normal oc´s applyed, now if trm watchdog is active, it will abort boot when it sees the first gpu in intit sequence, i can go around that by lowering oc´s but thats not the way this should work, and still dead gpu error every now and then with trm watchdog. i do understand the function and importance of watcdog…im applying extreme measures to even to be able to boot up my system, after i get it up n running its stable…no invalids,no stales…just hashing. “Are you saying that with watchdog disabled TRM starts hashing without issue when cards are overclocked within Hive ???” yes. like i have mentioned ealier, im all amd btw. thats why i allsi tried to chance init sequence to 3= all gpus at the same time…

yes im the same in terms of once hashing trm is super stable with the rx580 cards setup correctly. I’m 100% share’s accepted since last boot which is sometime now. Obviously i started TRM with hiveos having no overclocks applied to cards at all and then once running i applied the overclock profile. I have the TRM watchdog enabled and no dead gpu message since getting all the card overclocks super stable. Before when using simply the hive community shared configs the rig was unstable and maybe a dead gpu from watchdog every 6 hours or so. But like i say since cards setup properly i’m no longer having that issue and gpu’s temps sitting nice around 50-54c with fans on auto only at most 30%. TRM doing a nice job in that respect.

Also do you have any idea why when i set my voltage to 850mv in hiveos overclock section TRM reports in console card voltage to be 950mv ? Seemed strange being that I had set the undervolt along with the clock settings etc and clock settings all worked by reflection of increased hash rate yet the undervolt seemed to have not got through to TRM. Any clues appreciated.

& yes i have read all the TRM documentation and some options need better explaiing such as the --eth config

-eth_config=CONFIG Manual ethash configuration for the miner. CONFIG must be in the form [M][L].
The [M] value selects the mode which can be ‘A’,‘B’, or ‘C’.
The ‘B’ mode uses additional memory and will only work on 8+GB cards.
The ‘C’ mode uses additional memory and will only work on 16+GB cards, such as the VII, with
a correctly configured system. See the ETHASH_TUNING_GUIDE.txt for more details.
The [L] value selects the intensity and it’s range will depend on the GPU architecture.
Both values are optional, but if [L] is specified, [M] must also be specified.
Example configs: --eth_config=A
–eth_config=B750
CONFIG can also be a comma separated list of config values where each is
applied to each GPU. For example: --eth_config=A,B750,A288
Any gpu that does not have a specific config in the list will use the first
config in the list.

I thought maybe setting manual tune on all the cards from configs would stop the autotune from happening and thus causing TRM to fail startup when an overclock profile is active in hive. It is how to write the syntax for say a 12 card system . Would it simply be like this : -

-eth_config=A123,A356,A254,A143,A256,A254…etc for all 12 gpu’s based on the console report from a previous trm autotune ?

I assume reading the documentation there is no reference of the tuning number to a specific gpu and the codes just follows logical thought in that A123=GPU0 A356=GPU1 this list would grow historically dependant on how many gu’s are present in the system.

thx
tony

here few of my 5xx gpus oc. Setting stays even after cold boot. TRM give a bit lower hash than phoenix, dont know the real life benefit…i assume that 24hrs real hash is more or less the same even the reported is higher??.. and on this rig with vega´s allso increasing some of values affects the other ones, like they are stealing amps from eachothers xd . My experiences about autofan is all bad, 115 error,cpu temp unreal etc, so im not usin that, hive is contorolling fans anyway. config for mode is --eth_config A / B etc with B config i have experienced instability and havent really got any significant benefits, tho that enables some other conf´s to be appyled. Im bacically with stock atm with trm, only watchdog disabled, when and if i get dead gpu, i will enable watcdog back in action, but for now it seems to be working so …im not touching anything :smiley:

hi,
i have mine nice and stable and overclocks i am using are in the image. TRM wont start though with that config whatsoever so i have to apply overclocks once it begins hashing at .

What i meant in my previous post when specifying the —eth_config parameters ; do you not need to specify a reference to which gpu is having which autotune setting or is it like i said just a logical order gpu0,gpu1,gpu2 etc etc ?

thx
tony

no, all configs are done on gui without any extra parameters on flight sheet or anywhere, and they have stay´d as is after miner restatrt,reboot,cold boot…since i started to use hive actually. Only when flash the whole hive image naturally its mandatory to apply oc´s again… btw, i went to latest oc with TRM, enabled TRM watchdog and straight away started to get dead gpu errors again…

1 Like

watchdog for trm off and no further issues starting with my overclocks.

do you know why though i am unable to set my mV to 850 for the core ? I set in hive to this setting yet trm always reports 950mV ??

thx again tony

Do you have set DPM value (core state) ? I use 1. If not set default is 5 and that might bring your mV up

hi i have my config above. I have core set at 1210 , dpm 4 m VDD at 850 . The VDD should be the core voltage from reading the hive docs. Like i said i’ve set to this 850 in hive yet when i look at the trm in console it states the core voltage to be at 950mv which is higher than i wanted to run. thx again tony

oh, sory missed that. I belive there is lots of reports that actual consume is more than set @ gui. Maybe i should check my consumption stats allso :wink:

yep, i simply consoled to the rig and watched the miner running and very clearly trm states the core to be at 950mv.

You aint the only one mate my 580’s are set at 850Mhz but miner reports 950Mhz.

Anyone know why this is happening?