Teamredminer failed to initialize device idx 4 (-7)

So as the title says teamredminer wont load on startup. I had no problem 3 days ago but i installed a new GPU (RTX 3060) in the main 16xpcie and now the 2x 570 and 1x 580 wont load in teamredminer. NBminer works perfectly but has low hashrate, around 8-9 on each card.

Im using lolminer as the other miner with a rx 580 8gb and 3060 mining raven with t-rex

did u manage to solve this? i have same thing going on.

Not yet, maybe its the new HiveOS update?

If you like, u might wanto try reistall your amd drivers, its straight forward prosess.
For a guided installation enter the following 3 commands in hive shell,

wget https://raw.githubusercontent.com/CryptoLuigi/AMD_installer/master/amd_install.sh

chmod +x ./amd_install.sh

./amd_install.sh

I’ve tried that and tried to flash a new HiveOS. Doesn’t seem to work yet. I will not give up tho!

2 Likes

Same here. Im using a 5700xt gigabyte stockbios

I think I might of found my fix. I have a 3060ti first then a 5700xt. But they say both gpu 0. So I was putting teamredminer to mine on gpu 1 since it’s the second one. Didn’t work. I put it 0 and viola. They are both on 0. And mining fine and stable. Try it. tell me if it worked for you :muscle:

Dude it worked perfectly. I had my nvidia cards on 0 and 1 and my 8gb card on 0 and the rest on 1,2,3 and worked perf :slight_smile:

So to put it simple i just ignored the nvidia cards and started 0,1,2,3 on the AMD cards

Glad to hear it. Issues with having both amd and nvidia. But atleast it works now. Happy mining bro