Thread 0 has invalid config ''xmr-stak"

#1

hi,
I want to test xmr stack but I have a configuration problem

thread 0 has invalid config

configuration :

can you help me please ? :smiley:

TY

#2

gpu_threads is not needed so remove it.

Not sure if this is the problem, but platform index was usually at the end in my config…

Also, not sure if strided_index, mem_chunk and comp_mode are mandatory config params per thread or not…

Those are differeces from what I am using…

#3

Seems like your miner’s config has deprecated style so miner can’t recognize it

  1. First at all option gpu_threads_num not used in miner. No code in miner for this option. Maybe long long time ago miner has this option but not now - it’s deprecated. So you can remove it from config.
  2. Correct thread has syntax:
{ "index" : 0, "intensity" : 800, "worksize" : 8, "affine_to_cpu" : false, "strided_index" : 1, "mem_chunk" : 2, "comp_mode" : true }