Нашёл несколько багов

#1

Умерла в очередной раз винда смертью храбрых (ушла в бутлуп) и вместо очередной переустановки ее решил попробовать что-нибудь на Линукс. Долго выбирал между SMOS и HiveOS и выбрал последнюю. Возился с ней несколько дней, перематерился, но т.к. она мне понравилась и я хочу, чтобы она развивалась, решил зафиксировать те баги (или фичи?) что я в ней нашел:

  1. Самое печальное для меня было то, что вроде при заявленной поддержке карт R9 280/x, на самом деле сейчас они “из коробки” не работают (по крайней мере в Клейморе), а учитывая их “особую особенность”, что за 8 т.р. на вторичке они выдают 25-30 мх/с (т.е. примерно как RX570) на форках эфира (Pirl, Expanse, Music), имхо, списывать их со счетов рано. Так вот, если просто из коробки развернуть свежий HiveOS, то Клеймор даже не запустится. Он будет выдавать ошибку “Cannot build OpenCL program for GPU 0” (и так для каждой видяхи). Слава богу на этом форуме у кого-то уже была такая проблема и решается она очень просто. Нужно всего-то открыть файл /Hive/bin/claymore, найти там строчку
    #export GPU_FORCE_64BIT_PTR=0
    раскоментить ее и выставить в единичку. Т.е. так:
    export GPU_FORCE_64BIT_PTR=1

Всё, после этого Клеймор начнет запускаться, но карты работать всё равно не будут. :)) Скорость у них будет всегда 0 h/s. А через какое-то время Клеймор будет рестартится по таймауту. Но это я тоже победил. См. следующий пункт.

  1. Нам надо в конфиге клеймора выставить “-asm 0” (ну или “ASM: 0”, если это в ewallet ставить). После этого всё стартует и начинает майнить. После этого у HiveOS из коробки есть поддержка R9 280 и 280x (а также их полные аналоги HD 7950 и HD 7970). У меня как раз в риге вперемешку 8 таких карт и все они заработали. Но обидно, что вообще все эти переменные нельзя задавать из веба.

Да, поддержка этих карт в HiveOS после этого будет весьма условной. Разгон не работает, контроль вентиляторов не работает, так что в конфиге Клеймора выставляем “-tt 1” и довольствуемся управлением вентиляторами из биоса. Кстати, если стандартное управление вентилями не нравится, подтюнить его можно из VBE 7.0.0.7, но для этого нам, конечно, понадобится винда. А для одной из 8 карт у меня еще и температура не считывается (показывает всегда 0 градусов). Но зато сами карты майнят, причем примерно на 10-20% быстрее, чем в винде. Конкретный пример, одна карта в винде давала не больше 20 мх/с, а в HiveOS выдает 28 мх/с (тот же клеймор, тот же конфиг). Правда нужен еще параметр “-etha 1”. Он у меня вообще стартанул по умолчанию именно такой, но это может зависеть от версий, так что я его прописал в конфиге принудительно.

  1. В процессе всех этих экспериментов был обнаружен следующий баг. Если в риге находится 8 карт, то в начале монитор показывает загрузку, стартует серверную часть, а вот потом, когда он уже должен показать окно клиента, на черном экране в верхнем левом углу моргает курсор (точнее знак подчеркивания) и больше ничего не происходит. Мигает он бесконечно. При этом HiveOS запустился и начинает майнить, всё окей, если подключиться к нему по SSH, то там всё работает. Но вот на локальном мониторе - нет. И в принципе это не проблема, когда ты уже всё настроил, но я эту проблему поймал при первичной загрузке ОС, когда еще ничего не настроено. И долго плясал с бубном, пока не догадался выдернуть одну карту. На 7 картах всё заработало. Поспрашивал у другого человека с HiveOS и 8 картами, он сказал, что у него было ровно так же. Мать - Esonic на 8 карт (вроде hm76.65 модель).

  2. Ещё один глюк - когда я выдернул GPU4 (т.е. пятую карту), т.к. ей как раз надо было биос шить в другом виндовом компе, то HiveOS на оставшихся 7 картах вообще не стал грузиться в принципе. Никак. Но стоило мне переткнуть восьмую карту в пустующий пятый слот - как сразу всё загрузилось. Т.е. грузится оно только если карты воткнуты подряд в порты. Без дырок. Причем, в этом случае загрузчик не грузится вообще. Хотя железо всё работает, т.к. если успеть зажать “del”, то мы попадаем в биос и там картинка есть. Но при перезагрузке, после POST дальше бесконечно черный экран и никакого загрузчика.

Дальше пойдут не столько баги, сколько вопросы и/или пожелания:

  1. В файле /hive/Claymore/latest/config.txt уже вписаны, например, такие параметры как “-tt 68”, “-ttli 76”, “-tstop 82”. Проблема в том, что где их править из веба - я так и не понял (может плохо искал?), да в файле есть сноска “DONT EDIT THIS FILE, IT WILL BE OVERWTITTEN AFTER UPDATE”, но где в итоге это править - так и не написано. Т.е. я понимаю где можно добавить новые ключи в этот файл. Но как удалить те, что в нем есть?! И проблема в том, что эти параметры мне очень мешают, т.к. R9 - карты безумно горячие и ttli ставить меньше 86-88 градусов там бессмысленно. Особенно летом. Ну ладно, это хотя бы можно перекрыть конфигом (просто в конфиг еще раз запишется, например “-tt 1” и оно будет иметь приоритет над штатным “-tt 68”. Но всё равно хочется понять как это править в вебе корректно.
  2. Нельзя запустить несколько клейморов одновременно. А это важно, например, для экономии на devfee. Для карт с 2Gb оперативки (а у меня и для некоторых 3-гиговых) отсутствует devfee, однако, надо чтобы в этом клейморе не было ни одной карты с большим объёмом памяти. А у меня из 8 карт одна имеет 6 gb, в итоге devfee применяется ко всем 8 картам. Если же запустить 2 разные копии Клеймора и в одной указать 6-гиговую карту, а в другом все остальные, то devfee будет идти только в одном окне клеймора, а второе окно будет без devfee. Но из-за того, что HiveOS использует не ключи запуска, а файл epools, запустить один клеймор с двумя разными epools - невозможно. В теории, это можно было бы обойти тем, что одно окно бы запускалось из версии 11.7, а другое из 11.6 (там разные epools), но и этого сделать тоже нельзя. Увы. :frowning: Ждём HiveOS 2.0
#2
  1. Где вы нашли поддержку 2хх/3хх. Карты официально не поддерживаются.

Авто неоднократно писал что поддержка этих карт не планируется. Все изыски что они как-то работают это заслуга сообщества.
Насколько я знаю планов по официальной поддержке этих карт по крайней мере еще недавно не было.

  1. Есть клеймор оверайд. Я бы в отдельный пункт это даже не выносил.

  2. на ригах с 8+ картами это известный факт, хотя у меня включена встроенная ВК и я с таким не столкнулся

  3. Проблемы запуска на материнках которые китайцы наштамповали на волне популярности майнинг как такового. Это точечные проблемы таких материнок которые нужно изучать индивидульно

#3
  1. Пользовательские значения будут иметь приоритет перед прописанными в этом файле. Это проверено, хотя возможно и не совсем корректно сделано.
    И нет, вы не поняли самого главного - не в epools.txt дело.
    Функция Second miner - в принципе не поддерживает двух майнеров. Для этой фичи что 11.6 что 11.7 это один майнер. В текущей архитектуре не планируется что-либо менять, но это есть в планах HiveOS 2.0

За потраченное время на отзыв все равно спасибо, я обязательно передам автору

#4

3 и 4 пункт. а что в тех документации материнки описано? в какие слоты надо первыми подключать?

#5

Монитор надо подключать в интегрированную видеокарту на материнке, при этом в биосе следует выставить что бы она выбиралась первой, тогда все нормально стартует и локально монитор работает. Работает и на 8 и на 12 картах.

Сами карты можно втыкать в любые слоты, у меня материнки на 12 портов, куда хочешь туда и втыкай, при изменении только порядок карт в системе меняется, но все работает. Все эти китайские есонеки самые плохие материнки для майнинга, на них и показатели производительности по картам несколько ниже, чем на нормальных. Экономия боком выходит.