Не устанавливается скорость вентиляторов

fan-speed
#1

Доброго времени суток!
Обновил я у себя на ригах версию hiveOs и следом запустил обновление драйвера nvidia
установилась версия драйвера 396.54
И после этого не могу установить скорость вращения вентиляторов на постоянку.
До этого все прекрасно работало в настройках разгона видеокарты ставил тупо 80 и вентилятору крутили на 80 а сейчас что я только не пробовал и -tt 1 ставил и в настройках autofan в верхней панели пробовал - нифига.
Делаю запрос mine rconfig и там в конфиге написано -tt 68 и как я вижу работает майнер по этим настройкам… и другие не принимает
Попробовал сменить мяйнер и алгоритм и тоже результата - ноль
Вентиляторы живут своей жизнью

Что делать?

#2

никогда на зеленых этот параметр не ролял, тем более под линукс
Цитирую:

#3

чем тогда объяснить? и как вернуть чтоб было как раньше?

#4

Проблема аналогичная, на зеленых, обновился со старой версии, и обновил драйвер, и все вентиряторы стали жить своей жизнью, 20-30% разброс на картах… перепробывал все варианты, отключить и включать автофан, насройки -тт… не помогает. заметил одно при выполнении: >gpu-fans-find2
выдает :
Sat Sep 15 03:17:48 EEST 2018
================START Search GPU script===========
00:02.0 Intel Corporation HD Graphics 610 (rev 04)
0 03:00.0 GeForce GTX 1060 3GB (3019 MiB, 120.00 W)
1 07:00.0 GeForce GTX 1060 3GB (3019 MiB, 120.00 W)
2 08:00.0 GeForce GTX 1060 3GB (3019 MiB, 120.00 W)
3 0a:00.0 GeForce GTX 1060 3GB (3019 MiB, 120.00 W)
4 0b:00.0 GeForce GTX 1060 3GB (3019 MiB, 120.00 W)
5 0c:00.0 GeForce GTX 1060 3GB (3019 MiB, 120.00 W)
6 0d:00.0 GeForce GTX 1060 3GB (3019 MiB, 120.00 W)
7 0e:00.0 GeForce GTX 1060 3GB (3019 MiB, 120.00 W)

Stopping miner session
Stopping screen session 2752
nvidia-persistenced failed to initialize. Check syslog for more details.
Stopping Fans
Notice: If you have AMD GPU with GPU temp 511 this fan will not be stopped!
Set All NVIDIA Fans to 0…

Spinning fans on GPU 1 03:00.0 GeForce GTX 1060 3GB /hive/bin/gpu-fans-find: line 50: 17742 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=100 > /dev/null
…/hive/bin/gpu-fans-find: line 50: 17751 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=0 > /dev/null
OK
Spinning fans on GPU 2 07:00.0 GeForce GTX 1060 3GB /hive/bin/gpu-fans-find: line 50: 17909 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=100 > /dev/null
…/hive/bin/gpu-fans-find: line 50: 17918 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=0 > /dev/null
OK
Spinning fans on GPU 3 08:00.0 GeForce GTX 1060 3GB /hive/bin/gpu-fans-find: line 50: 17933 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=100 > /dev/null
…/hive/bin/gpu-fans-find: line 50: 18098 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=0 > /dev/null
OK
Spinning fans on GPU 4 0a:00.0 GeForce GTX 1060 3GB /hive/bin/gpu-fans-find: line 50: 18114 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=100 > /dev/null
…/hive/bin/gpu-fans-find: line 50: 18265 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=0 > /dev/null
OK
Spinning fans on GPU 5 0b:00.0 GeForce GTX 1060 3GB /hive/bin/gpu-fans-find: line 50: 18280 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=100 > /dev/null
…/hive/bin/gpu-fans-find: line 50: 18289 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=0 > /dev/null
OK
Spinning fans on GPU 6 0c:00.0 GeForce GTX 1060 3GB /hive/bin/gpu-fans-find: line 50: 18447 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=100 > /dev/null
…/hive/bin/gpu-fans-find: line 50: 18468 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=0 > /dev/null
OK
Spinning fans on GPU 7 0d:00.0 GeForce GTX 1060 3GB /hive/bin/gpu-fans-find: line 50: 18483 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=100 > /dev/null
…/hive/bin/gpu-fans-find: line 50: 18636 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=0 > /dev/null
OK
Spinning fans on GPU 8 0e:00.0 GeForce GTX 1060 3GB /hive/bin/gpu-fans-find: line 50: 18651 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=100 > /dev/null
…/hive/bin/gpu-fans-find: line 50: 18802 Segmentation fault nvidia-settings -a [gpu:$cardno]/GPUFanControlState=1 -a [fan:$cardno]/GPUTargetFanSpeed=0 > /dev/null
OK

Restoring OC settings…
nvidia-persistenced failed to initialize. Check syslog for more details.
OK
Restarting miner session
Starting claymore

#5

как откатить назад драйвер?
заметил что производительность на картах тоже снизилась… место 24 мх стало 19мх, при тех же настройках.

#6

Sat Sep 15 03:31:26 2018
±----------------------------------------------------------------------------+
| NVIDIA-SMI 396.54 Driver Version: 396.54 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 106… On | 00000000:03:00.0 Off | N/A |
| 25% 55C P2 61W / 60W | 2854MiB / 3019MiB | 98% Default |
±------------------------------±---------------------±---------------------+
| 1 GeForce GTX 106… On | 00000000:07:00.0 Off | N/A |
| 28% 55C P2 59W / 60W | 2854MiB / 3019MiB | 98% Default |
±------------------------------±---------------------±---------------------+
| 2 GeForce GTX 106… On | 00000000:08:00.0 Off | N/A |
| 33% 58C P2 61W / 60W | 2854MiB / 3019MiB | 96% Default |
±------------------------------±---------------------±---------------------+
| 3 GeForce GTX 106… On | 00000000:0A:00.0 Off | N/A |
| 21% 55C P2 57W / 60W | 2854MiB / 3019MiB | 95% Default |
±------------------------------±---------------------±---------------------+
| 4 GeForce GTX 106… On | 00000000:0B:00.0 Off | N/A |
| 24% 55C P2 58W / 60W | 2854MiB / 3019MiB | 99% Default |
±------------------------------±---------------------±---------------------+

резал мощность, что бы хоть как то карты не перегревались, ранее была температура 35-40 и мощность 80 ватт

P/S

скачал образ 73 последний, перезаписал флешку, и стало все норм, управление вертиляторами заработало. Производительность карт стало такой же как было…

#7

Короче решил я проблему откатом драйвера.
Делал ручками. Зашел на риг по ssh, остановил майнер и xinit унинсталил драйвер и поставил старый.
давайте распишу команды:

  1. Цепляемся к ригу по SSH (я использовал Putty)
  2. miner stop
  3. killall xinit
    4 можно дальше через mc работать а можно и командной строкой
  4. cd /hive-drivers-pack
  5. NVIDIA-Linux-x86_64-390.25.run -x
  6. cd NVIDIA-Linux-x86_64-390.25
  7. nvidia-installer --uninstall
  8. reboot
  9. после загрузки опять miner stop
  10. killall xinit
  11. cd /hive-drivers-pack/NVIDIA-Linux-x86_64-390.25
  12. nvidia-installer
  13. после установки опять reboot и всё :slight_smile:
  14. Радуемся
1 Like