Trex 0.24.0 lhr dual mining unlock

Can we get this to work in HiveOS yet?


You can ssh into the box and manually download 0.24.0 for now. The following steps worked for me

Start a remote hive shell

cd /hive/miners/t-rex/
mkdir 0.24.0
cd 0.24.0
tar -xzf t-rex-0.24.0-linux.tar.gz
cd ../0.23.2
mv t-rex t-rex.old
ln -s ../0.24.0/t-rex .

Edit: Fixed typo in mv command

After that make sure you have your flight sheet setup properly with

"lhr-algo": "autolykos2"
"url2": "stratum+tcp://"
"user2": "9egdBGusi1PzxrPiKcrhwUAx1LoevBq1usNqQH2sQ9gF6SHWmu8.rig0/"
"pass2": "x"

and then restart your miner the 0.23.2 t-rex in the drop down menu will now run the 0.24.0 trex miner

If you launch the miner screen you can watch it start and see the 0.24.0 print out

I sold 2 x 3070ti yesterday. Looks like I will regret for that

Thank you for info. You might be first one to install this t-rex version to HiveOS :slight_smile:

I’ll just wait till official hive announce, but in a meantime, let me ask few questions.
-Did dual mining really worked on HiveOS?
-How did it displayed on Hive screen? Since the GUI of hive is designed based on “One GPU, one algo”, I just can’t imagine how Hive will show One GPU with dual algo.

It works. I was able to mine ~31 MH/s ETH and ~150 MH/s ERGO on my 3080 LHR.

Correct the HiveOS display will only show the hashrate for ETH. In order to see the ERGO hashrate you either need to connect to the HiveOS shell and run the miner command to see the text output from the running t-rex process. Or you can also run a miner log command from the web UI and you should be able to see the ERGO hashrate.

Miner log output:

The hashrate does jump around a bunch. Also room for improvement on those ERGO numbers. I haven’t tried to optimize it yet.

I imagine the delay in the HiveOS release is to fix up to web UI so it can properly display two hashrates for dual mining with t-rex.

1 Like

Thanx! It is really really valuable!

I completely agree with you about delay of Hive, since its not generic change of importing repository of miner, it might take several days to fix gui logic itself under the hood.

Anyway glad to hear its working and at least didn’t break gui logic :slight_smile:

Thank for the Information,
Forget that i respond to an old version of the forum Should I see the Kapow algo in Hive side by side the eth mh?
I think I have only the eth working the second algo dont seems to kick in, and the pool dont seems to see it… I will try again tomorow maybe in the miner screen on the pc I will see better what up.
btw is there a way to have the miner screen from the hive interface ?
I will try the shell thanks!

Yeah I mess something in your instruction I dont run the 24 version…

1 Like

Make sure you add the additional flight sheet config options for the second pool. It doesn’t use any of the HiveOS %WALL% and %WORKER_NAME% values so you need to make sure your url2 has all the correct information in it.

“lhr-algo”: “autolykos2”
“url2”: “stratum+tcp://”
“user2”: “9egdBGusi1PzxrPiKcrhwUAx1LoevBq1usNqQH2sQ9gF6SHWmu8.rig0/”
“pass2”: “x”

You can run the miner log command from the web UI if you want to see the ERGO hash rate

The flight sheet will still say you are running 0.23.2:

But it is actually running 0.24.0 on the box:

1 Like

I tried to follow the commands but it stays at 0.23.2 :confused:

unable to create dual mining flightsheet. I think it can’t be created from Android hiveos app. I must need to login to web through a pc. Am i right?

Make sure that the t-rex binary in the 0.23.2 folder points to the 0.24.0 t-rex binary

Start out by creating a normal ETH coin flight sheet for t-rex miner. Then setup the extra config arguments to be

"worker": "%WORKER_NAME%"
"lhr-algo": "autolykos2"
"url2": "stratum+tcp://"
"user2": "9egdBGusi1PzxrPiKcrhwUAx1LoevBq1usNqQH2sQ9gF6SHWmu8.rig0/"
"pass2": "x"

You will only have one t-rex entry in your flight sheet for mining ETH all of the ERGO magic happens in the extra config arguments

1 Like

Yes it says the same but no lucky :confused: oh well

I cant even upgrade my OS

Last update with new Trex i tryed 5 mn ago has fail on all my rigs

same here

did you figure out a solution for it

I think we should wait, it is os problem…

Dual Mining works, issue with updating OS version has fixed itself, try running Version 0.6-209@210906 and upgrading to newest.