Unable to dual mine Eth+Erg on the same rig [solved]

I’ve got three Vega 56/64 rigs, and I want to use them to mine Ergo. Two of them have 2-3 GPUs that overheat on Ergo, so I’ve been trying to set up a flight sheet that will mine Ergo (with Teamredminer) on all the cards that do not overheat, and Eth on the cards that do overheat. I’ve tried Phoenixminer, SRBminer, and even a custom TRM package (I would prefer to use TRM), but am unable to get either rig to start hashing. I’ve attached screenshots of my flight sheet–with the custom TRM install and with Phoenixminer. I’ve also attached a screenshot of what happens when I try to mine with TRM and Phoenixminer. I was able to get TRM to mine on 6 of the GPUs, but Phoenixminer never got the other cards hashing. Most of the time the rig just reboots or freezes up.

The custom TRM install is available here: https://github.com/billkenney/teamredminer/releases/download/v0.8.4c/trminer.tar.gz

If anyone could let me know how to get this working I’d appreciate it.

[quote=“afargo, post:1, topic:45700”]

In this image you Custom seems to be for the Phoenix miner? Yet the Custom configuration seems to be for tminer.

The custom setup is for Teamredminer. The flight sheet won’t let you use the stock Teamredminer twice, so the only way to potentially use it is by setting it up as a custom miner.

The first part of my flight seem (for Teamredminer) stays the same regardless of which other miner I try to use. I’ve tried to use Phoenixminer (as shown in the screenshot you posted), SRBminer, lolminer, and a custom TRM setup (as shown in my other screenshot). When I have it set up as Phoenixminer, SRBminer, or lolminer, the flight sheet has the name of the miner in the configuration, it only has custom when I’m trying to set up a second TRM miner.

Have you tried running without any OC?

Just tried running the TRM/Phoenixminer flight sheet with no overclocking. The agent-screen still says “failed to read teamredminer from localhost:65078” almost immediately. A couple attempts later it says “failed to read phoenixminer stats_raw from localhost:3335.” Both errors are intermittently thrown on every hash attempt. The rig usually reboots after a minute or two.

Have tested it lately with just one miner, to verify that has to being set up with two miners, instead of one?

Yes, I’ve been running TRM on these rigs mining Eth since March/April. Whenever I’m unable to get the dual mining setup working, I switch it back to mining Eth with TRM. TRM is currently running on all of my rigs right now, two of them mining Eth and one mining Erg. The problem is that I’m unable to set up dual mining to deal with the 2-3 GPUs that overheat when mining Erg on miner1 and miner3.

I think I’m out of suggestions at the moment and wish I could be more help. :frowning: A slight work around if it was me is I would move the GPU’s that tend to overheat with Ergo to one rig so that I only have to figure out with one rig what’s going on.

I would move the GPUs around, but the heat problem is likely a result of my setup. I have all of my rigs in my basement covered with a tarp, and air is circulated from outside with an in-line fan which exhausts the air. The GPUs closest to the wall tend to get hotter than the others, and those are the ones overheating when mining Erg.

I appreciate the advice. Hopefully I’ll be able to figure this out.

After “sleeping on it,” no solutions. But I’ve noticed when I have more than miner running on a rig that the seems to be less stable and having to reboot it. Using TRex and lolminer (because of 3060), though not as bad as what you have been experiencing. I’ve also noticed that there are several thread where people are having trouble with keeping rig stable with more than one miner on a rig ( some of which I’ve seen you respond to).

I first tried about a week ago, but haven’t been able to get it working. For now I’ll stick to mining Eth on those rigs. Hopefully this will be fixed before Eth moves over to POS.

Same thing happens to me anytime I try mining eth and ergo at the same time it restarts and shuts down miner running eth while ergo is still able to run I dual mine metaverse and ravencoin with eth and have no problems it only does this with ergo…

Very strange. Maybe I’ll try mining RVN instead. Glad I’m not the only one.

Yea when I first installed hive it worked but after updating a couple times seems like it became unstable I would get a bunch of diffrent errors.

That’s interesting. Both of my 5700xt rigs constantly reboot if I upgrade past 0.6-203, but I’m trying to dual mine on my Vega rigs. I wonder if downgrading would fix the issue… I’ll give it a shot when I have the time.

Heh, just ditched win10 to try my hand at ergo and eth on hive for better vega state locking, only found this post after 2 nights of trying to get trm and lolminer to hash eth and ergo respectively, but it’s good to know that shits broken on Hive for everyone so I can bugger off back to win10’s unstable-but-working dumpster fire.

I got it working again it started happening dual mining ergo and eth then yesterday it started happening with raven coin and eth today for both it would keep mining ergo while my gpus mining eth would just disappear on screen same thing started happening with raven coin an eth last night would keep mining raven and the gpu mining eth would disappear on screen throwing no restart messages etc so I hooked up a monitor to see if a error was being thrown I couldn’t see sure enough it was error process information pid 0 gpu 3 timeout said something like that so I downgraded and unhooked all risers off cards then replaced them on after that everything worked again no problems dual mining now they don’t disappear or crash it’s been 8 hours

What version did you downgrade to?

0.6-193@210118 I would unplug the risers from the cards the reseat them before downgrading that’s what I did it’s been about 10 hours still stable no problems changed flight sheets couple times to make sure it wouldn’t crash or throw any errors either so far only 1 rejected share within 8 hours

@kvng-ode is it still running? Could you post a screenshot of your flight sheet? I’m wondering which is your first miner and whether it’s mining Eth or Erg, and which is your second miner. Also, if you’re using Teamredminer, are you using -d 0,1,2 or --devices=0,1,2 to select the GPUs?