Unstable network connection

TLDR: Rig is displayed as offline on hive os webapp despite mining, it comes back online when I run “hello” or “net-test” but only for a few seconds, then it goes back to “offline”, as if the connection is sleeping

Hi all,

my rig is displaying as offline on hiveos, however it’s still mining on nanopool.

It transitions between offline and online on the web app, it’s usually displayed as offline ~99% of the time.

Sometimes when I type “hello” or “net-test” it comes back online on the web app, as if the connection was sleeping, but then it immediately turns back offline on web app.

Other times, hello outputs
“ERROR: Connection to API server failed (http://api.hiveos.farm)”
“CURLE_COULDNT_CONNECT (7) Failed to connect() to host or proxy.”

Sometimes when I do net-test, everything outputs as “ok”.

Other times, net-test outputs
“[FAIL] Check firewall rules or connection settings”
“[FAIL] Check firewall rules”
“[FAIL] Check DNS or connection settings”

What I’ve tried so far:

  • Switched Hive OS Version from 0.6-189@210104 to 0.6-191@210109
  • Switched miners from PhoenixMiner to lolMiner (both mine well and are working properly according to nanopool)
  • Switched from USB wifi adapter to wired
  • pinging google.com (0% packet loss)

I encountered this issue for the first time yesterday.
My first thought was that it was probably hive os servers so I didn’t bother with it yesterday, however it’s still happening today and I’ve asked if others are experiencing the same issue and they’ve denied it.

I don’t think it’s my router/modem, they’re always working properly (home network)

Has anybody else encountered this?

Fixed by enabling DoH for all and running
dnscrypt -i && sreboot

1 Like

I have configured 2 rigs and the only way to make them work is THIS !!!
dnscrypt -i && sreboot

I tried this and still get the following

Hello, it gave me the same problem. Could you help me, I don’t know where to enable the Doh?