Update info on UEFI boot

Hello, I just set up my first HiveOS rig and I’m not writing this for my own benefit but to save others in the future from going through all the trouble that I went through.

All the information provided (in the KB , as well as in the pinned thread in this forum) states that you cannot boot from UEFI, that you need to boot in legacy mode or that you need to enable the CSM.

I found this to be false, outdated information. Using the latest beta, I found that it does boot from UEFI out of the box. Maybe I am mistaken. Maybe I am thinking that I’m booting from UEFI, when I am not. But I don’t think so. I found a prepared EFI System Partition (ESP) in the HiveOS image that I downloaded.

As a result of the information telling me that booting from UEFI is not possible, I spent a considerable amount of time researching how to make HiveOS boot from UEFI. I researched how to manually create the EFI partition, etc.

tldr: If I’m not mistaken, if it does boot from UEFI out of the box, please update the documentation, the forum sticky threads, the KB to reflect that.

1 Like

Thanks for posting!! Honesty. A million times. You did save me a ton of time. I saw this elaborate procedure to create a new ESP boot directory, etc and was not looking forward to it especially since I know jack about Linux.
I had to disable CSM support recently for resizable BAR on the gaming PC so I could not access the MBR partition I was using to boot from, but two new ones came up. Not sure why there is two. Partition 1 does not work, but Partition 3 does. It even reads the rig.conf from the MBR partition so I didn’t need to setup anything it just keeps cooking with all my settings.
I noticed those partitions before in Windows after flashing the drive, but couldn’t read them there.

yes,i have the same question。