Update RX6800 February / 2021

Radeon™ Software for Linux® 20.45 Release Notes

Article Number


Release Date: December 17, 2020

This article provides information on the latest version of Radeon™ Software for Linux®.

Radeon™ Software for Linux® 20.45 Highlights

  • Provides support for the Radeon RX 6900/6800 Series of graphics cards

Fixed Issues

  • Ubuntu 20.04 kernel update to 5.4.0-56.62 causes compilation of its amdgpu kernel module to fail.

Known Issues

  • A Total War: Three Kingdoms hang may be observed while running in benchmark mode on Radeon 6800 series graphics
  • Blue color corruption may be observed while running Unigine Heaven
  • Blender 2.90.1 users may experience page faults (details in dmesg log).
  • Proton 5.13-2 has a known critical issue (driver fails to load) which affects AMDVLK for this release; as a temporary workaround, it is suggested to use an earlier Proton release, namely Proton 5.0-10. Please note that this Proton bug does not affect our upstream driver.
  • User may experience issues when utilizing OpenCL in multimedia use cases.

Package Contents

  • AMDGPU All-Open and AMDGPU-Pro Driver

Radeon™ Software for Linux® can be downloaded from the following links:

By clicking the Download button, you are confirming that you have read and agreed to be bound by the terms and conditions of the End User License Agreement (“EULA”) linked to this note for use of AMD Proprietary OpenGL, OpenCL™, and Vulkan™ drivers provided by this download. Open source software is also provided and is subject to the terms and conditions of the licenses included with such software. If you do not agree to the terms and conditions of these licenses, you do not have a license to any of the AMD software provided by this download.

Installing Radeon™ Software for Linux®

  1. Using the downloaded driver package

For detailed instructions on how to install or uninstall Radeon™ Software for Linux®, you can find the latest version of the installation instructions by extracting the downloaded archive, and opening /doc/index.html in your browser – this should be considered as the most up-to-date version of the documentation.

You can also refer to our readthedocs.io documentation: Radeon™ Software for Linux® installation instructions

To use the Vulkan driver in this stack, Vulkan SDK version 1.2.148 needs to be installed. The SDK can be downloaded from: https://vulkan.lunarg.com/sdk/home
2. Using the Upstream version

AMD has been working with the open source community and provides an out-of-the-box experience for the majority of Linux users, by having its driver upstreamed. This means that you do not have to download a driver to make your graphics card work; the support should already be there when you install your favourite Linux distribution. AMDGPU, our all-open graphics driver for Linux, can be used with all our Radeon HD 7000 series or newer. To get support for our latest graphics cards (Radeon RX 6x00 series), here are the components that you will need:

Kernel 5.10 or newer
Mesa 20.2 (or optionally, Oibaf mesa 21.0 from here: Updated Open Graphics Drivers - since 2011! : Oibaf)
llvm 11.0 or newer

Firmware files for your card (either from the packaged driver, or here: (either from the packaged driver, or here: Linux Firmware amdgpu Daily : Darxus). Note that, if your distribution does not have the necessary files already (they are usually inside /lib/firmware/amdgpu) you will need to copy them there manually. By adding the firmware files by hand, you are essentially going behind your package manager’s back. This should be considered a temporary measure until your distribution’s firmware package picks up the necessary files, so caution is advised. Instructions follow for Ubuntu-based distributions and the 20.45 driver package; please adapt to your specific distribution and the amdgpu-dkms-firmware version included in the downloaded driver package:

  • Extract the files from the downloaded driver archive.
  • Extract the firmware package to tmp:$ dpkg -x amdgpu-dkms-firmware_5.6.20.906300-1164792_all.deb tmp
  • Find the firmware of your card in the tmp (example below is for Radeon RX 6800 series of cards):
    $ find tmp/ -name sienna_cichlid*
  • Copy the firmware files to the default location:
    $ sudo cp tmp/usr/src/amdgpu-* /lib/firmware/amdgpu/
  • Update your initramfs:
    $ sudo update-initramfs -u

AMD Radeon™ Product Family Compatibility

Radeon™ Software for Linux® is compatible with the following AMD products.

AMD Product Family Compatibility

AMD Radeon™ RX 6900/6800 Series Graphics AMD Radeon™ R9 360 Graphics
AMD Radeon™ RX 5700/5600/5500 Series Graphics AMD Radeon™ Pro WX-series
AMD Radeon™ VII Series Graphics​ AMD Radeon™ Pro WX 9100
AMD Radeon™ RX Vega Series Graphics AMD Radeon™ Pro WX 8200
AMD Radeon™ Vega Frontier Edition AMD FirePro™ W9100
AMD Radeon™ RX 550/560/570/580/590 Series Graphics AMD FirePro™ W8100
AMD Radeon™ RX 460/470/480 Graphics AMD FirePro™ W7100
AMD Radeon™ Pro Duo AMD FirePro™ W5100
AMD Radeon™ R9 Fury/Fury X/Nano Graphics AMD FirePro™ W4300
AMD Radeon™ R9 380/380X/390/390X Graphics
​AMD Radeon™ R9 285/290/290X Graphics

Compatible 64-bit Operating Systems

  • Ubuntu 20.04.1
  • RHEL/CentOS 7.9
  • RHEL/CentOS 8.2

OBS: If it helps someone else with their tests

Still don`t know how to do this

I still have a problem , i install the alpha version but not detect card correctly.
Card model : XFX Speedster Merc319 Radeon RX 6800 XT

1 Like

Did you install HiveOS from scratch with this RX6800XT card or use the update over an existing installation via SSH as it suggested?

Could you try adding more than 8GB to see if you recognize it? Because it seems to me that the amount of memory in this case is associated. If you have another 8GB slope to get 16GB and we’ll see.

I’m sure the developers are watching all the reports and screens posted on that topic, I even forwarded a direct link to that topic to one of them.

The more people who report their cases with a wealth of information the better.

1 Like

I’m now attempting this, and not having any luck. Here’s my history: I was mining on a pair of Radeon R9 390 flawlessly, and am now trying to add a couple 6800XTs. I was running the latest stable version of HiveOS (before I had seen this post). When I booted up the rig, the new cards were visible on startup, but the temperature, fan speed, and wattage readouts were not there - the R9 390 was there and did show the data. Phoenix miner only showed one GPU (the R9 390), and if I ran the amd-info command, only one GPU was listed.

Since seeing this post, I did an in-place ‘upgrade’ to the suggested alpha version here and rebooted the rig. I immediately noticed a difference: on startup, the 6800XTs showed the temperature, fan speed and wattage, so I thought I had success. Upon checking Phoenix miner, it did now detect the three GPUs, but the hash rates for the 6800XTs are zero, and Phoenix miner keeps restarting to try to get them going.

So, I wiped the drive and used Etcher to re-flash the drive with the alpha image. I booted that image with the same result - 6800XTs are detected, but hash-rate is zero.

Here’s my setup: Asus B550-Plus motherboard, Ryzen 5 2400G processor, 8GB DDR4 (I tried upgrading to 16GB once per the previous post, but that didn’t help).

1 Like

I will try to run 6900XT from ASROCK on this image. I will share the test results on Friday, 2021-02-26.

1 Like

I just got this to work! Saw another post suggesting using TeamRedMiner instead of Phoenixminer. It is now up and running. Here’s what I did: I changed my flight sheet to use TeamRedMiner, then I re-flashed the alpha image to my boot drive and booted the rig through the one-time setup. TeamRedMiner was erroring out, and on checking into it, it no longer supports my R9 390. So, I modified my flight sheet to use PhoenixMiner for GPU 1 and TeamRedMiner for GPUs 2 and 3. Everything seems to be humming along. I’ll let it run for a while, then will play with some overclocking/undervolting.


Cara funcionou!!!

I used the Alpha, made a new bootable device, DON’T upgrade … Phoenixminer 5.4b
core clock: 1200 mem clock:2150… 59-57MH

its working … with my others two rx5500xt together…

one thing that i have notice its the pendrive speed… i have done this configurations in one pendrive that in my point of view was tooooo slow[abbout 2x slower just booting], so a have changed the pendrive and… voila… its working [sandisk, that one red and black!!]…

valeu ai !!!

1 Like

don’t mix amd with nvidia

1 Like

There is nothing wrong with mixing AMD and Nvidia on HiveOS. It doesn’t experience the limitations that Windows does.

However, for Big Navi & Nvidia, it’s currently not supported on Alpha and you will need to receive the Beta version from a developer. You can ask in the Discord channel, I’m active frequently there and will direct you to where you need to go.

1 Like

Hi! Is it possible tha you shared the Beta version? I just mounted a rig with one 3070 and to 6800xt, and I’m frustrated. Thanks in advance. (I connected to discord Hive.OS, but I see no channels on the server)


Hi! I´m connected to the HiveOS Discord, but I did´t see any channel! Could you tell me or send me an invitation to that channel? Many thanks!

Hello thanks for the alpha link.

So, I’ve seen 2 exacts same outcomes.

  • Beta to Alpha from “ssh” → bootloops
  • Alpha iso → bootloops
    NB: GPU is now recognised as 6800.

I’ve 2 6800 (primary) and 1 5700
In all cases I don’t have GUI (this is fine)

I’ll try to enable logs to pinpoint the issue.

1 Like

Olá, bom dia!

Também sou Brasileiro e estou com esse mesmo problema.
Infelizmente eu tenho uma 2080 e acabei de comprar uma 6800 Sapphire Pulse e não estou conseguindo inicializar. Por favor, você pode incluir meu nome na lista?

Obrigado por sua ajuda.

Obs.: Estou acompanhando diariamente seu tópico.


1 Like

Será feito o teste somente hoje, minha placa mãe estava em manutenção

1 Like

Whoever good that everyone is collaborating with their reports, it is certainly very important that everyone leave their experiences registered here in this topic to make life easier for those who are experiencing difficulties in using this RX6800 card.

Could you please provide here in this topic the link of the beta version friend itsZeroday.

I do not have the beta version. As I have stated, you have to join the Discord server and then a dev will get it to you when they get a chance.

1 Like

Well. I’m on discord but no channels shown.

1 Like

I’m still having trouble making my 6800 card mine, I downloaded the 6800 specific image configuration, I used rufus to unzip the file, I did the procedure to add the farm correctly according to the code taken from the hive os, all just as standard as i used the rx 570 8gb, when i started in linux bios my computer just shut down in two attempts, thus restarting, by any chance the source needs a lot of energy to make the card run? why does the rx 6800 require at least 650 wats, and my source is 600wats? is that it? because I saw several people mining with 3 3070 plates in a 650 source and normal wheel, I would only use the 6800 and rx 570 at first.

1 Like