Vega 56 and Vega 64 guide

So, I have had a lot of issues finding guides on OCing these cards. I’ve finally found a stable setup and I’de like to help others by sharing mine.

I have 5 cards, 4 Vega 56 and 1 Vega 64. I’ve read a lot of stuff online and I’ll start with things that do NOT work for me:

  1. Vega 64 BIOS on Vega 56 Samsung memory cards. Just does not do it for me. At all. Always unstable. Can’t get higher clocks
  2. Vega 64 BIOS on Vega 64 cards. Also unstable in the long run.

These are the things that work for me:

  1. Vega 56 BIOS on all cards (56 and 64). I makes my Vega 64 more stable. I do not get more than 50 MH/s on her, but I get my 50 constantly and without problems.
  2. Vega 56 clocks: 1075 core, 850 vdd, 950/60 mem as a starting point (some cards I raise up to 980 on mem) - seems like a great baseline for all.
  3. Vega 64 clocks: 1000 core, 850 vdd, 950/60 mem as a starting point
  4. straps for all: --CL 20 --RAS 22 --RCDRD 12 --RCDWR 12 --RC 36 --RP 12 --RRDS 3 --RRDL 5 --RTP 5 --FAW 12 --CWL 8 --WTRS 4 --WTRL 9 --WR 13 --REF 65000 --RFC 249

All in all, the system seems stable now at these settings :slight_smile:
When I had only the 3 Vega 56 in the system, I could push em a bit higher, but now I cant, because they somehow affect other cards in the system. But when I apply the straps. I get more out of them than before. So, I’m happy :slight_smile:

My from the wall wattage is 970 W, measured by the HS110.

  • GPU 3 is a Vega 64 with a 56 BIOS

Things to do: try out lower fan settings and maybe get a cheap ssd for the rig.

my setup:
Motherboard: B450 Pro4 ASRock
CPU: AMD Ryzen 7 1700
Disk Model: ATA ST3400620AS 400GB
PSU: Corsair HX1200

I use teamredminer and I’m mining ETH

Pro tips :smiley:

  1. tune TeamRedMiner with this line for slight power savings: --eth_config=B

  2. for manual restarting the rig, use a TP-Link HS110 smart plug. Connects to your WIFI, measures socket wattage and enables you to power on/of the plug manually from your mobile phone

  3. enable Restore On Power Loss in your MOBO BIOS. This way the rig turns on when the electricity is on. Combined with the HS110 you can restart your rig from your phone

  4. Vegas can “die” in TRM and TRM will restart the rig. Not a problem, but you will need to enable auto application of your straps. Use xinit.user.sh for it. For more info, visit this link: Help with xinit.user.sh and saving Amdmemorytweak strap

Hope this helps :slight_smile: If you have any advice, I’m open :slight_smile:

if this guide helped you, like it, comment etc. If you can, consider donating:

  • ETH: 0x4b3F87c44C06D19c31b431c67B1a46A8eC1EECe1
  • RVN: R9ZTPBwx5RYxeNqgApuZgJVVvDLsgQQtwE
  • Paypal: PayPal.Me

I will continue to update it with new info.

4 Likes

how do you adjust the straps please ? sorry newbie

1 Like

click run command. Then write:
amdmemtweak --CL 20 --RAS 26 --RCDRD 12 --RCDWR 12 --RC 38 --RP 12 --RRDS 3 --RRDL 5 --RTP 6 --FAW 12 --CWL 8 --WTRS 4 --WTRL 9 --WR 13 --REF 24000 --RFC 239

this will strap this to all cards

thanks finally sorted its so easy once you know lol

got my card up to nearly 45mh with these settings dont want to push it too far cant get the power down though any ideas ? thanks

That is a vega 56 or 64 with 56 bios? The wattage seems high. Also the frequency

its a 56 i lowered the frequency to 975 only getting 43.5mh now no reduction in power

apply the straps at the end. maybe up the fan a bit. seems hot

oh and are you using teamredminer?

will try that do i have to do straps every time it reboots or applies new settings ? thanks for your help

every restart I think. Everytime you OC something, got to apply straps. Have not figured out if you can do it automaticly.
btw definetly use teamredminer

ahh may be where im going wrong im using pheonix

YES. Use teamredminer. It will restart a few times I think. When it stabilizes, apply straps

Here you go. Remember to go to worker options and enable the GUI on boot.

2 Likes

After almost two days of testing, I also came to pretty much the same conclusions you have.

My system has been stable for the past 48+ hours on the following settings.

  1. I flashed all 6 of my cards to their equivalent 56 BIOS
  2. Set TRM to “–eth_config=B” (in hopes of drawing a little less power)
  3. Had to bump my VDD to 875 (unstable at 850)
  4. Using this strap: --RAS 26 --RCDRD 12 --RC 38 --RRDS 3 --RRDL 4 --REF 21000 (I noticed my cards running at 80% minimum fan speed when I used you’re posted strap)

My Setup:
MB: ASUS B250 Mining Expert
CPU: Intel Celeron G3930
GPUs: 6x Vega 64
Disk Model: ??? I’m running HiveOS completely off a 32GB Jumpdrive

Using TRM and mining ETH via NH

1 Like

Nice. Seems the wattage is low and they seem stable :slight_smile:

Have you managed to improve your MH/s?

I have managed to lower my fans by 20%. Nothing monumental, but its a lot more quiet :smiley:

Which version of HiveOS are you using?
I am using 0.6-195@210127 on 5.4.80-hiveos (standard)
I have a Gigabyte Gaming OC Vega 64 and flashing to 56 kills it.
I am running KawPow on the Vega using nanominer 3.1.5
Also running a RX5500XT on same board mining ETC on nbminer 36.1

image

no cant seem to improve on 45mh?