WIFI driver nl80211 / rtl8188eu / 0bda:f179 Realtek Semiconductor card

Hi, Im sharing this info people may benefit if they stuck with clueless to fix their installation of Realtek wifi nano dongle.
my wifi dongle reports the model of 8188eu by default with Hive os (ubuntu)

on lsub :
Bus 001 Device 002: ID 0bda:f179 Realtek Semiconductor Corp.

lshw -C network

       description: Wireless interface
       physical id: 1
       bus info: usb@1:2
       logical name: wlan0
       serial: 00:e0:25:31:00:85
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8188eu ip= ​multicast=yes wireless=IEEE 802.11bgn

on wifi cmd:

     ​Vendor: Realtek Semiconductor Corp.
     ​Model: 802.11n

The problem is *eu is little bit old driver and not compatible with new devices or kernels, It doesn’t scan my Access points.

After several research, followed the below steps will solve the requirements to have have wifi connection ready.
Note : This may work or not work on onboarded wifi comes with motherboards. but may work on USB wifi devices.

Most of them were using this git repo for updated drivers ( not official) and kudos to kelebek333 for maintaining the repo. hence i followed the same. https://github.com/kelebek333/rtl8188fu.git

How to install rtl8188fu ( new driver)

# sudo apt-get install build-essential git dkms linux-headers-$(uname -r)

# git clone https://github.com/kelebek333/rtl8188fu

# dkms add ./rtl8188fu

# dkms build rtl8188fu/1.0

# dkms install rtl8188fu/1.0

# cp ./rtl8188fu/firmware/rtl8188fufw.bin /lib/firmware/rtlwifi/

Run following commands for disable power management and plugging/replugging issues.

# mkdir -p /etc/modprobe.d/

# touch /etc/modprobe.d/rtl8188fu.conf

# echo "options rtl8188fu rtw_power_mgnt=0 rtw_enusbss=0" | sudo tee /etc/modprobe.d/rtl8188fu.conf

You are done with new driver installation, now Lets remove old drivers

Remove the old *eu drivers from the kernel /system. (use sudo as prefix if you not a root user)

# rmmod 8188eu
# apt purge rtl8188eu
# dkms status
       # dkms remove rtl8188eu/4.1.4 --all
       # dkms remove rtl8188eu/1.0 --all
       These commands useful if dkms reports the package installed through this dkms cmd
# mv /lib/firmware/rtlwifi/rtl8188eufw.bin /bkp/
# mv /etc/modprobe.d/rtl8188eu.conf /bkp
# echo "blacklist 8188eu" | tee /etc/modprobe.d/8188eu-blacklist.conf

# lsmod | grep 81
ensure your drivers are removed and only listed the recent drivers. in my case 8188fu

After installing any new DKMS driver (or creating a new blacklist file), run the following commands in the terminal:

# depmod -a

# mkinitcpio -P

Now you done with all set of commands. Remove your wifi dongle and do reboot.
Be sure to do a complete shutdown. The device could possibly retain old settings if you do a warm reboot.

After reboot insert your dongle. and run below commands

# wpa_passphrase YOUR_AP_NAME YOUR_PASSWORD >> /etc/wpa_supplicant/wpa_supplicant.conf

or you can do this with wifi command

# wifi   ( follow the instructions as per the screen ) 

Add below lines to get activated on boot.

# vi /etc/network/interfaces

allow-hotplug wlan0
iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

once again reboot and check your wifi is connected.
Tips : some useful commands ``` ip addr , ifconfig , iwconfig, wpa_supplicant, iwlist wlan0 scan