WiFi setup



[quote=“DimaFern;53”]These devices fully work:

148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter Realtek RTL8188CUS

DOES NOT WORK: TP-LINK TL-WN725N works with options described in comment below.


Please help!


MT7601U is https://ru.aliexpress.com/item/Mini-USB-WiFi-Adapter-N-802-11-b-g-n-Wi-Fi-Dongle-High-Gain-150Mbps/32819666725.html


TP-LINK TL-WN822N tested and working - better than small usb adapters (two anttenas and long USB cable)
wifi command runned and to be sure just added following lines in /etc/network/interfaces

auto wlan0
iface wlan0 inet dhcp


What to do?


try a different network adapter.


in hiveos version 0.5-30 MT7601U works!


Not working for me.


Отлично работал вайфай пока не полез настраивать чтобы он сам поднимался после перезагрузки.
Настраивал в директории etc/network/ файл interfaces и случайно сохранил пустой файл. Возможно после этого вайфай перестал работать. Поделитесь кто-нить кодом который в файле прописан по умолчанию.


В арче все подхватывается без проблем. В hive кернел сыплет device descriptor read error. Т.е. не вопрос линукса, а проблема в сборке hive. В какую сторону покопать?

Realtek Semiconductor Corp. RTL8192EU 802.11b/g/n WLAN Adapter



Just moved to HiveOS. Very nice OS! My only issue is with Realtek RTL8811AU 802.11ac USB 2.0 That is not recognize by HIVEOS when i do the wifi command, it say “No wlan0 interface found”. I ran the “lsusb” but its not clear if the Realtek listed there is the onboard NIC or the USB wifi dongle.

What should i do to make it work? Thanks!


Replying to myself, here is what I did to make it work :smile:

sudo apt purge rtl8812au-dkms
sudo apt install git
git clone https://github.com/gnab/rtl8812au.git
sudo cp -r rtl8812au  /usr/src/rtl8812au-4.2.2
sudo dkms add -m rtl8812au -v 4.2.2
sudo dkms build -m rtl8812au -v 4.2.2
sudo dkms install -m rtl8812au -v 4.2.2

after that, I just ran the “wifi” command and the adapter was found. I entered my ssid, password, and it connected. It wrote config. Then, I rebooted without Ethernet plugged in, and it auto-connected :slight_smile:


А если на WIFI нет пароля, что делать? Если его просто пропустить, то пишет Empty value и опять его требует.


Знающие люди, помогите пожалуйста. Тоже проблема с вайфаем, ссид и пароль не запоминает, приходиться вводить каждый раз после перезагрузки. Видел что советовали отредактировать файл /etc/network/interfaces, так вот, как до него добраться и отредактировать? Пробовал через sftp в тотал комадире, но там не дает его сохранить после редактирования.


How can I disable wifi after it has been setup? When I type “wifi” it only asks for IP address etc but there is no option to disable wifi.


For disabling wifi you need to execute command



Не получается поднять wifi. при команде #wifi ввожу SSID и пароль, ругается с ошибкой too many simbolic links.
ifconfig адаптер видит, но к сети не подключается.
Куда копнуть не подскажете?


Cause HiveOS is buuild on Ubuntu 16.04 Xenial you will find help in Ubuntu Forums.
WLAN runs out of the box in Ubuntu.
If not it is a problem between several drivers or a missing firmware package.
Just do a Google search at: “Ubuntu 16.04” Your Wlan Adapter or: “Ubuntu Xenial” Your Wlan Adapter. In most cases you have to blacklist some other drivers or load additional firmwarepackage and you are ready to go.


Just updated my rig(s) to ver.0.5-54. Why HiveOS still doesn’t connect to hidden wifi? Please, follow my simple solution: find in /hive/sbin/wifi at line 117

wpa_passphrase "$WIFI_SSID" "$WIFI_PASSWORD" |tee /etc/wpa_supplicant/wpa_supplicant.conf

and replace it with

wpa_passphrase "$WIFI_SSID" "$WIFI_PASSWORD" | sed -e "s/\}/	scan_ssid=1
\}/g" |tee /etc/wpa_supplicant/wpa_supplicant.conf

this whill add additional option “scan_ssid=1” to wpa supplicant config file. then reboot and enjoy!
Or do you know some more elegance solution?
Anyway, I hope this whill helps… to someone :wink:


So does anyone know a cheap wifi adapter that i can plug in and someone has already figured out how to get it to start and connect to the internet on reboot that someone can tell me about? And give me what i need to type to get the drivers.


Several month ago bought on AliExpress for only 2.95 USD Wi-Fi which fully supported by HiveOS (MT7601U inside)

promo price today - 2.85 USD