WiFi setup

wifi
network

#41

@HaloGenius is their anything else that i need to run? Such as drivers to install? Or is it just plug and play?


#42

@MiningYeti
Drivers integrated to HiveOS. PNP and no pain )


#43

Ребятушки , дело такое есть WIFI Adapter TP-LINK Acher T2UH на них очень хорошие антенны стоят и получается хорошая связь , ну в винде проверено а вот установить их не получается , хайв не видит к сожалению… Пытался сам поставить не получилось Вопрос такой может вы будете добавлять когда то драйвера в сборки можете и его добавить ???
https://www.tp-link.com/de/download/Archer-T2UH_V1.html#Driver
или можете как то помочь его установить ??


#44

Just wanted to add that the Amazon Basics Wifi adapter works without any additional work. Just plugged it in (after HiveOS was loaded), typed “wifi” and everything connected flawlessly.


#45

Заказал такой себе. Попытаюсь заставить работать, но на случай неудачи присоединяюсь к просьбе добавить поддержку в сборку)


#46

#47

https://tr.aliexpress.com/item/kebidu-150M-USB-2-0-WiFi-Wireless-Network-Card-802-11-b-g-n-LAN-Antenna/32827792641.html
with antenna


#48

The same trouble. After deployment I have used command ‘wifi’ and it works properly, but after reboot it doesn’t work anymore. The same error: ‘too many symbolic links’


Every time it works only in the first boot.
I tried to edit etc/network/interfaces - doesn’t work too.
Adapter TL-WN821N, drivers by default. HaveOS v. 0.5-57
Any idea - how can I fix it?


#49

So, I built a farm with same adapter about 3-4 months ago. Now I have tried the same (old) HiveOS distrib, and it works without any problems (after installing the drivers).


#50

У меня получилось запустить Acher T1U. Думаю решение должно подойти и к T2UH.
I have solutions for Acher T1U:

  1. mkdir src
  2. cd src
  3. wget https://github.com/xtknight/mt7610u-linksys-ae6000-wifi-fixes/archive/master.zip
  4. unzip master.zip
  5. cd mt7610u-linksys-ae6000-wifi-fixes-master
  6. make
  7. make install
  8. modprobe mt7610u_sta
  9. vi /etc/network/interfaces
  10. Добавьте эти строки в файл. insert this strings:

auto ra0
iface ra0 inet dhcp
wpa-ssid ****
wpa-psk ****

wpa-psk получаем командой wpa_passphrase [ ssid ] [ passphrase ]
11. if up ra0

Вот и всё. После ребута wifi автоматом подключается.

Проверено на текущей версии Hive OS 0.5-67


#51

I hope this isn’t a dead thread but I just recently switched to HiveOS from Windows and it seems much easier to use but I am unable to use wifi on a Realtek mt7601 wireless adapter. When I type the wifi command I receive the message “No wlan0 interface found”. I have tried every guide I could possibly find on the internet and have reinstalled my HiveOS multiple times with different versions but I just can’t get the wifi command to work. I am having the same errors as the person here and it seems “mrgromov” found a fix but I don’t fully steps 2 and 3 as I am not very familiar with linux.
Does anyone have an easy fix? Thank you

EDIT After two days of fighting with the adapter I got another one I had ordered in the mail and decided to try a fresh install with it and immediately it worked perfectly with the wifi command. To anybody reading this in the future who has the same problem as me I suggest you just get a new one, sometimes they can just be fucked with linux, despite working on windows as in my case.


#52

Worked for me too. Tenda U12 AC1300 USB adapter working fine.

Thanks pducharme!


#53

hi im new to hive os and linux, can someone tell me how to reconect mi wifi after a reboot? some say to do a config file, but i really dont know how to do it!


#54

Подскажите как добавить драйвер от TP-Link TL-WN821N V6.0.
ссылка на сайт с драйвером https://www.tp-link.com/ru-ua/download/TL-WN821N.html#Driver
Или пусть разработчик его добавит с обновой
Иначе после перезагрузки он не запускается.
Спасибо