XMR Stak, CN heavy, rx580 8gb, max 650 h\s


#1

Доброго времени суток

Проблема в следующем: XMR Stak риг 6 карт (rx580 8gb), даёт 670 h\s с одной карты в одном потоке. 350 h\s и 350 h\s в двух потоках. Интернет говорит о том что эти карты должны давить не менее 1000 h\s. Прошивка, а так же тайминги биоса (bits.media) были произведены. При установке одной карты в систему windows, при запуске майнера SRB, XMR Stak, проблема сохраняется (файл подкачки 15гб).

Что было сделано: различные настройки xmr stak, настройки частот памяти и ядра , даунгрейт hiveos (после вернули обратно на 5.74).

Тест производился на картах: rx580 8 gb Gigabyte SK Hynix, Sapphire SK Hynix, ASUS Samsung,

Скриншоты прикрепляю.


#2

Hi, I had the same hash problem and instability. I solved it by downloading the OC, core 1275 and memory 2100.

Also you can upload in the configuration

“gpu_threads_conf”: [
{“index”: 0, “intensity”: 1000, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: 1, “mem_chunk”: 2, “comp_mode”: true},
{“index”: 0, “intensity”: 1004, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: 1, “mem_chunk”: 2, “comp_mode”: true},
{“index”: 1, “intensity”: 1004, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: 1, “mem_chunk”: 2, “comp_mode”: true},
{“index”: 1, “intensity”: 1008, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: 1, “mem_chunk”: 2, “comp_mode”: true},


#3

Смените образ на 0.5-57 с последующим обновлением до крайней версии и будете приятно удивлены результатами на криптонайт

По конфигурации - в целом нормально, но пару замечаний:

  1. Удивлен, что многие также пишут параметр "gpu_threads_num" - его нет в коде майнера !!!
  2. mem_chunk начните со стандартного 2 вместо 16

#4

Все сделано исходя из ваших рекомендаций.

Результата нет.

Скриншоты, с очередностью действий, прилагаю.

Команда “gpu_threads_num” по моему наблюдению, влияет только на количество отображаемых\задействованных карт.


#5

Она не может влиять ни на что потому что этого параметра нет в коде майнера. Как может влиять то чего нет?
Возможно когда-то такой параметр был, но сейчас его нет в исходный кодах майнера.

Вы суслика тут видите?
%D0%B8%D0%B7%D0%BE%D0%B1%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5


#6

Нет не сделано …
Версия ядра линукс должна быть 4.13 и драйвера АМД 18.10 - все это доступно в образе 0.5-57.
Я вижу все тоже самое что и первом посту.


#7

I am running those cards even on AMD drivers 17.50. I haven’t seen any improvements on driver upgrades, so I am still sticking with the old ones…


#8

I am using 3 RX 570 and 3 RX 580 cards, with AMD drivers 18.10 and Hiveos 0.5.72, working very well 6.1 kHs


#9

Did you try running it on 17.5 drivers? I have seen slight hash rate decrease when migrating from 17.5 to newer versions.

I have to point out that I am not pushing OC settings so high as you do. I am running them at 1100 core clock. Mem at 300 since I haven’t seen any improvements on having high mem clock. I have checked Aggressive undervoltage and cards are reporting 60-70watts (compared to 80-100 that you have).


#10

Драйвера под криптонайт лучше 17.50 для этого накатите образ 5.32, и будет 1000+


#11


#12

а как ето сдиелать?как накатите образ 5.32 ?


#13

Образ hiveos 5.32 на наситель (ssd или usb) запиши и всё


#14

а где её скачать?


#15

Эту версию уже убрали, устарела. Просите у админа форума, или скачайте последнюю, я пробовал и 18.10 и 18.20, но 17.50 у меня работает лучше всех.


#16

You can use new images of HiveOs and downgrade the drivers. Here is a post about changing the driver version:


#17

17.50 чеу это номер ?драиверов?


#18

Да это версия драйвера


#19

как Сделалать downgrade АМД драиверов?


#20

Procedure is explained in the post I quoted. There is README file in /hive-drivers-pack so you can check there as well.

Anyway, download 17.50 version from:
http://download.hiveos.farm/drivers/amdgpu-pro-17.50-511655.tar.xz
and put it in /hive-drivers-pack.

Follow README procedure to uninstall existing drivers and to install new drivers. When running script to install driver add this to command line “–opencl=legacy” if you have RX5xx or RX4xx cards.

After that - reboot your rig and that’s it…


Drivers Update