XMR Stak configuration Requsted


#1

Hello Guys ,
Need help with XMR Stak configuration to mine CN-Heavy on NiceHash .
My RIG :
8 x RX 580 8gb Sapphire Nitro+ ( bios Moded )
Thank you


#2

Here is what I have there, but this will very much depend on your cards, BIOS mod, …


“gpu_threads_conf” :
[
{ “index” : 0, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 16, “comp_mode” : true
},
{ “index” : 0, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 16, “comp_mode” : true
},
],
“platform_index” : 0


This is for dual threaded mining on one card - just copy and change index for other cards. Play around with intensity and worksize to find which settings give you the best results in terms of hash rate and stability.

Also, to be noted, I get around 5-7% rejected shares from NiceHash with xmr-stak… And in OC - you can lower mem clock to 300 for this algo and RX580 series cards… It doesn’t affect hash rate but lowers power consumption.


#3

thank you givo i got this erorr


#4

check your config options for syntax
according screenshot - bad format in amd settings from start


#5

i copy it from AMD config override


#6

Did you (by mistake) copy and this free-text “To disable AMD GPUs”?? By the error message (as @HaloGenius has mentioned) - there is surely a syntax error in your AMD config override section.

Can you copy/paste what you have in there, or click on Miner->Config and copy/paste that part and we’ll figure it out…


#7

This is my Config :
“gpu_threads_conf” : [{ “index” : 0, “intensity” : 768, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true},{ “index” : 1, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true},{ “index” : 2, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true},{ “index” : 3, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true}, ], “platform_index” : 0,


#8

Try with this:
“gpu_threads_conf” :
[
{ “index” : 0, “intensity” : 768, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 16, “comp_mode” : true},
{ “index” : 1, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 16, “comp_mode” : true},
{ “index” : 2, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 16, “comp_mode” : true},
{ “index” : 3, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 16, “comp_mode” : true},
],

“platform_index” : 0


#10

this is what i got :
[2018-08-28 23:02:18] : Mining coin: cryptonight_heavy
WARNING: NVIDIA Unable to query number of CUDA devices!
[2018-08-28 23:02:18] : WARNING: backend NVIDIA disabled.
[2018-08-28 23:02:18] : JSON config parse error in ‘amd.txt’ (offset 1): Missing a name for object member.

xmr-stak exited, waiting to cooldown a bit


#11

This is very strange. Please, click on the worker in question, click on the little hammer icon on top and then on Miner Config:
image

Wait for a few seconds, and then click on the miner config reply message from the rig:
image

In the newly opened window, scroll down to amd.txt part and copy / paste what you have there. It should be something like this:


#12

=== /hive/xmr-stak/amd.txt =================================================
“gpu_threads_conf” :
[{ “index” : 0, “intensity” : 768, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 16, “comp_mode” : true},
{ “index” : 1, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 16, “comp_mode” : true},
{ “index” : 2, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 16, “comp_mode” : true},
{ “index” : 3, “intensity” : 864, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 16, “comp_mode” : true}, ],

“platform_index” : 0


#13

i`m gona test another rig with
2 x MSI RX580 8gb ARmor
2 x Asus Rog Strix RX580 T8G


#14

I have no more ideas, but the problem must be in that file. Maybe there is some kind of special character in the file that is messing you up.

I would ssh into rig, go to /hive/xmr-stak, stop miner, delete amd.txt and pools.txt and execute ./xmr-stak.sh. Miner would ask for pool, wallet, … and create amd.txt. Then use content of that file to paste it into miner config box in Hive dashboard… And then try to modify it…


#15

BTW, “offset 1” in your error message indicates that there is a problem in the first character in the file. Is there a space or any other hidden character at the beginning of the file. Try and delete quote sign and any other characters on the left of it and then type quote sign again as the first character in the file.


#16

Thank you givo for your help
i send you privet msg


#17

Thank You again givo for yous support .
Problem solved :


#18

I see you did nice job with fine tuning intensity and worksize… way to go!!

Happy mining…


#19

because of your help dude :wink:


#20

could you please share your amd.txt commands. i have same problem and could not split the gpus as you


#21

How many GPUs you have ?
and RX what ?