XMR Stak configuration Requsted


#22

This is my setting for 8 x RX580 8GB sapphire nitro+

“gpu_threads_conf” : [
{ “index” : 0,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 0,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 1,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 1,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 2,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 2,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 3,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 3,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 4,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 4,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 5,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 5,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 6,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 6,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 7,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
},
{ “index” : 7,
“intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true
}, ],
“platform_index” : 0,


#23

this ” was instead of this " and therefore an error
so much time wasted because of an different apostrophe
unbelievable
this forum needs to change formatting asap

EDIT: I’m past the typing errors, now i get “failed to find memory space for buffer eviction” if I go over 496 intensity


#24

Hey man, could you also help me with the same problem? I’m getting the error: “parse error in amd.txt (offset 121): Missing a name for object member.”

Here is my configuration:
“gpu_threads_conf” :
[ { “index” : 0, “intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk" : 8, “comp_mode” : true },
{ “index” : 0, “intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true }, { “index” : 1, “intensity” : 992, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true },
{ “index” : 1, “intensity” : 992, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 8, “comp_mode” : true },
{ “index” : 2, “intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 2, “comp_mode” : true },
{ “index” : 2, “intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : 2, “mem_chunk” : 2, “comp_mode” : true }, ]
“platform index” : 0,

Sorry to bother you with this! Thank you.


#25

I think you are missing comma after ] and before “platform index”


#26

Haha! Thank you very much man. Got it working. Very difficult to get all that syntax perfect. On another note, do you have experience running two threads on xmr-stak and fine tuning the variables (intensity, worksize, etc.)? I really appreciate you responding. I promise this is my last question! Thanks.


#27

2x rx580 Armor OC, 1x Sapphire Nitro rx580, 2x msi gxt1080 gaming

AMD Config Override-- ( this line not actually in config file)

“gpu_threads_conf” :
[
{ “index” : 0, “intensity” : 1056, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 2, “comp_mode” : true},
{ “index” : 0, “intensity” : 1056, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 2, “comp_mode” : true},
{ “index” : 1, “intensity” : 1056, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 2, “comp_mode” : true},
{ “index” : 1, “intensity” : 1056, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 2, “comp_mode” : true},
{ “index” : 2, “intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 8, “comp_mode” : true},
{ “index” : 2, “intensity” : 912, “worksize” : 8, “affine_to_cpu” : false, “strided_index” : true, “mem_chunk” : 8, “comp_mode” : true},
],
“platform_index” : 1,

Nvidia Config Override:

“gpu_threads_conf” :
[
{ “index” : 0, “threads” : 20, “blocks” : 80, “bfactor” : 0, “bsleep” : 0,
“affine_to_cpu” : false, “sync_mode” : 3,
},
{ “index” : 1, “threads” : 20, “blocks” : 80, “bfactor” : 0, “bsleep” : 0,
“affine_to_cpu” : false, “sync_mode” : 3,
},
],


#28

Those parameters are for real fine tuning and they depend on the card, memory size, vendor, algo, … many things. Intensity usually gives best results between 900 and 1024 (for 8GB cards). Worksize sometimes can go under 8. Mem chunk - I’ve had it on 16 many times…


#29

Alright, well I really appreciate your help! Sounds like it’s going to be a mix of more research and “guess-and-check”. The nvidia is MSI, the rx580s are MSI Radeon and the Sapphire is Radeon. Probably having similar cards would make this easier…haha. I’m mining cryptonight, Monero7. If you have any good resources about this stuff, let me know! I think I’m slowly figuring it out. Thanks again. You’re awesome.


#30

Maybe you can try and use some examples from this site:


#31

hi any one have config for RX580 4gb?i canot get more 220h/s per gpu.


#32

I’m lost !

I’m in HiveOS version 0.5-78

When i leave the “amd config override” empty, it works !
Well, not 1000/s but around 650 (my x5 cards are 580 8GB Pulse).

I would like to change this “amd config override” with a “gpu_threads_conf” to optimize that hashrate to around 1000/s, but whatever i put in the miner doesn’t work. It doesn’t lauch.
Syntax error ? I don’t know … but i checker all caracters.

[2018-10-20 22:16:32] : Mining coin: cryptonight_heavy
[2018-10-20 22:16:32] : NVIDIA: try to load library ‘xmrstak_cuda_backend_cuda10_0’
WARNING: NVIDIA cannot load backend library: libxmrstak_cuda_backend_cuda10_0.so: cannot open shared object file: No such file or directory
[2018-10-20 22:16:32] : NVIDIA: try to load library ‘xmrstak_cuda_backend_cuda9_2’
WARNING: NVIDIA cannot load backend library: libxmrstak_cuda_backend_cuda9_2.so: cannot open shared object file: No such file or directory
[2018-10-20 22:16:32] : NVIDIA: try to load library ‘xmrstak_cuda_backend’
WARNING: NVIDIA Insufficient driver!
[2018-10-20 22:16:32] : WARNING: backend NVIDIA disabled.
[2018-10-20 22:16:32] : JSON config parse error in ‘amd.txt’ (offset 1): Missing a name for object member.

I don’t see where is my parse error !

Please, i need help, and i’m not the only one it seems …

The config i tested :

“gpu_threads_conf”:
[
{ “index”: 0, “intensity”: 800, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: true, “mem_chunk”: 2, “unroll”: 8, “comp_mode”: true, },
{ “index”: 0, “intensity”: 800, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: true, “mem_chunk”: 2, “unroll”: 8, “comp_mode”: true, },
{ “index”: 1, “intensity”: 800, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: true, “mem_chunk”: 2, “unroll”: 8, “comp_mode”: true, },
{ “index”: 1, “intensity”: 800, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: true, “mem_chunk”: 2, “unroll”: 8, “comp_mode”: true, },
{ “index”: 2, “intensity”: 800, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: true, “mem_chunk”: 2, “unroll”: 8, “comp_mode”: true, },
{ “index”: 2, “intensity”: 800, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: true, “mem_chunk”: 2, “unroll”: 8, “comp_mode”: true, },
{ “index”: 3, “intensity”: 800, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: true, “mem_chunk”: 2, “unroll”: 8, “comp_mode”: true, },
{ “index”: 3, “intensity”: 800, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: true, “mem_chunk”: 2, “unroll”: 8, “comp_mode”: true, },
{ “index”: 4, “intensity”: 800, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: true, “mem_chunk”: 2, “unroll”: 8, “comp_mode”: true, },
{ “index”: 4, “intensity”: 800, “worksize”: 8, “affine_to_cpu”: false, “strided_index”: true, “mem_chunk”: 2, “unroll”: 8, “comp_mode”: true, },
],
“platform_index”: 0,


#33

Check quotes
It’s most frequently error

When you copy-paste some software (ex MS Word) can change symbol " to something like this ˝


#34

I’m soooo stupid …

Thanks !