XMR-Stak configuration update guide from v2.4 to v2.5

cryptonight
xmr-stak
monero
cryptonight-v8

#42

Вы наверное новенький в xmr-stak :sunglasses:
при двухпоточном режиме агент хайва (модуль сбора статистики) ждет данные от числа N карт, а майнер ему отдает N*2 потоков соотв. не хватает температур для статки и там что попало (((.
Они собственно вообще не соотв. тому что есть на самом деле.

В идеале такие данные нужно получать от майнера, но реалии говорят что это нужно делать своими силами. TBD

А нет и смысла и это объяснимо ТТХ карт. Это отдельная тема о тюнинге, а топик как бы совсем о другом.


#43

it’s working now


#44

good and again thanks for report


#45

Had problems with a rig, fixed it by removing amd.txt and running indeedminer. It recreated opencl cache files, then I rebuilt my amd.txt.
Finaly having my old rx550 working


#46

I have 2 workers. One is working fine, the other has 100% rejected shares. I’ve tried running the GPU stock, made sure it was on “monero” currency, I don’t know what else could be wrong. They’re all rx580. I’ve also tried running the “rejected shares” rig with the other rig “flight sheet” and it’s still at 100% rejected…


#47

Still have problems here. If I run without any amd.txt config, I have around 600 per card (rx570/580). As soon as I try to configure stuff, I get something like that in miner output:

hHASHRATE REPORT - AMD
| ID | 10s | 60s | 15m | ID | 10s | 60s | 15m |
| 0 | 164.4 | 164.4 | (na) | 1 | 164.5 | 164.4 | (na) |
| 2 | (na) | 137.2 | (na) | 3 | (na) | 137.2 | (na) |
| 4 | (na) | 125.9 | (na) | 5 | (na) | 125.8 | (na) |
| 6 | (na) | 162.1 | (na) | 7 | 161.8 | 162.1 | (na) |
| 8 | (na) | 160.9 | (na) | 9 | (na) | 161.1 | (na) |
| 10 | 158.5 | 158.2 | (na) | 11 | 158.7 | 158.2 | (na) |
| 12 | 158.6 | 160.0 | (na) | 13 | 158.7 | 160.0 | (na) |


#48

на этих настройках получил вот так



карты не стартуют, это 6 потоков проца


Custom miner: xmrig-amd
#49

Забыл добавить , мой конфиг для монероv8 у вас биттьюб, он на каком-то Хеви, но могу ошибаться. Судя по ошибке в майнере, следует снизить параметр intencity.


#50

Вы скрутили настройки интенсивности в край
Майнер в логе пишет чтобы умерили пыл
%D0%B8%D0%B7%D0%BE%D0%B1%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5

При первой ошибке дальнейшая обработка бекэнда (в данном случае АМД) останавливается


#51

// gpu: Ellesmere memory:8192 // compute units: 36 { “index” : 0, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true }, // gpu: Ellesmere memory:8192 // compute units: 36 { “index” : 0, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },


#52

Вот с такими настройками 77 карт работают. Все 588. Разгон core 1257/935. mem 2160-2260. Cryptonight heavy


#53

Очень важный момент это драйвера на 17.40 вы выше 900 наврятли выжмите, 17.50 работают отлично! 18.10 самсунг работает хорошо. 18.20 с теми-же таймингами не держит разгон как 17.50.


#54


#55

my bittube cannot run XMR stak with 5.78. before with 5.71 its ok. is there any idea how to run bittube with the new XMR?

i use this on 5.71
“gpu_threads_conf” :
[
{ “index” : 0, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 0, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 1, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 1, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 2, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 2, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 3, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 3, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 4, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 4, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 5, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
{ “index” : 5, “intensity” : 1000, “worksize” : 8, “affine_to_cpu” : false,
“strided_index” : true, “mem_chunk” : 2, “comp_mode” : true
},
],

“platform_index” : 0,

now i use this

“gpu_threads_conf” : [
{ “index” : 0, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 0, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 1, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 1, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 2, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 2, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 3, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 3, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 4, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 4, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 5, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
{ “index” : 5, “intensity” : 1008, “worksize” : 8, “affine_to_cpu” : true, “strided_index” : 2, “mem_chunk” : 16, “unroll” : 8, “comp_mode” : true },
],

“platform_index” : 0,

still doesn’t run. so sad


#56

Илья спасибо за резюме.
Держи краба! ) :+1:


#57

Покажи конфиг процессора.


#58

i cannot read russia


#59

“cpu_threads_conf” : null i use this for cpu


#60

worker status?


#61

hi, been struggling since last night with setting up XMR-Stak to mine XMR. i Keep on getting

AMD Invalid Result GPU ID 8

from all cards. 1 share accepted and the other 100 rejected

Any one that can help me please.

I did update to 0.5.79 already